Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I know there are plenty of questions very similar to these, but I've tried practically everything and it still isn't working. Some solutions get the wireless connection working, but it goes very slow and drops after a few minutes. Then it won't reconnect and keeps asking for password.

Hope you can help me. Thanks in advance.

This is the output for sudo lshw -C network

 *-network               
   description: Network controller
   product: BCM4312 802.11b/g LP-PHY
   vendor: Broadcom Corporation
   physical id: 0
   bus info: pci@0000:02:00.0
   version: 01
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress bus_master cap_list
   configuration: driver=b43-pci-bridge latency=0
   resources: irq:18 memory:f0300000-f0303fff
  *-network
       description: Ethernet interface
       product: AR8132 Fast Ethernet
       vendor: Atheros Communications Inc.
       physical id: 0
       bus info: pci@0000:05:00.0
       logical name: eth1
       version: c0
       serial: 00:23:5a:9b:6e:b1
       size: 100Mbit/s
       capacity: 100Mbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vpd bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=atl1c driverversion=1.0.1.0-NAPI duplex=full firmware=N/A ip=192.168.0.106 latency=0 link=yes multicast=yes port=twisted pair speed=100Mbit/s
       resources: irq:42 memory:f0200000-f023ffff ioport:a000(size=128)
  *-network
       description: Wireless interface
       physical id: 1
       logical name: wlan0
       serial: 00:24:2c:83:f0:81
       capabilities: ethernet physical wireless
       configuration: broadcast=yes driver=b43 driverversion=3.2.0-30-generic firmware=478.104 link=no multicast=yes wireless=IEEE 802.11bg

And for lsmod | grep b43

b43                   342643  0 
mac80211              436455  1 b43
cfg80211              178679  2 b43,mac80211
bcma                   25651  1 b43
ssb                    50691  1 b43

And for rfkill list

5: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
share|improve this question

2 Answers 2

So far, what has worked for me is booting using an older kernel (2.6.32, selected from the GRUB menu at start), and then calling sudo modprobe b43 at a Terminal. Then just clicked on "Enable wireless" if it isn't enabled.

Since I'm a bit of a noob, I don't know if this is a good idea or if I'm screwing everything. But I got wi-fi =D.

share|improve this answer

It took me a couple of hours of looking through forums to find that jockey doesnt like when the ati radeon graphics card driver and the wireless driver for bcm4312 are both installed. Luckily, it seems you dont really need the ati radeon graphics card driver...

  1. Open up Synaptic Package Manager and search for "ati"
  2. Remove the following drivers:
    • xserver-xorg-video-all
    • xserver-xorg-video-ati
    • xserver-xorg-video-radeon
    • xserver-xorg-video-mach64
    • xserver-xorg-video-r128
    • radeontool
  3. Your internet should work after restarting your computer.

Hope this works for other people!

PS. After I got my wireless up and running, I tried reinstalling the ati drivers, and that caused my wireless not to work again. I'm not sure why the two drivers are linked together, but my computer seems to be fine without the ati drivers.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.