Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using youtube-dl to download some videos from youtube. But when I write:


I get:

[youtube] Setting language
[youtube] rn_YodiJO6k: Downloading video webpage
[youtube] rn_YodiJO6k: Downloading video info webpage
[youtube] rn_YodiJO6k: Extracting video information

ERROR: unable to download video

What am I doing wrong?

share|improve this question
Did you try to watch that video? I can't access it from my country. – January Sep 29 '12 at 13:19
When I press this link Is shows it: – Rondogiannis Aristophanes Sep 29 '12 at 13:19
Is it a problem with this particular video, or with others as well? – January Sep 29 '12 at 13:22
All the videos I have tried – Rondogiannis Aristophanes Sep 29 '12 at 13:26
This is actually a bug, and I entered a launchpad bug * that refers to the upstream fix. – nealmcb Feb 18 '13 at 1:56
up vote 27 down vote accepted

Same question was asked on

Youtube changed something to make it incompatible with youtube-dl, it's been fixed in the latest version. Use the following to update youtube-dl until the package system gets the updated version:

sudo youtube-dl -U


As noted by sup in the comments youtube-dl is patched in Ubuntu to disable the --update option because of security concerns (the bugreport is here). It is also argued in the bugreport that youtube-dl is a moving target, so the version in the repositories is often out of date. This makes easy upgrade a necessity.

Easy upgrade is still possible with e.g. pip. Install like this (you may want to uninstall old versions of youtube-dl first):

sudo pip install youtube_dl

Upgrading can now be done with:

sudo pip install --upgrade youtube_dl

As documented on the youtube-dl download page. Note that similar security concerns are attached to this method as well.

share|improve this answer
Thank you very much!! – Rondogiannis Aristophanes Sep 29 '12 at 15:29
This no longer work: Install a new version from upstream: sudo wget -O /usr/local/bin/youtube-dl sudo chmod a+x /usr/local/bin/youtube-dl (info from here: ) – sup Nov 7 '13 at 21:41
@sup: I have added a pip alternative which is almost as convenient. – Thor Nov 8 '13 at 10:39
Cool, only it already is disabled, I edit your answer to reflect it. – sup Nov 8 '13 at 21:03

For me the following lines worked:

sudo apt-get remove -y youtube-dl
wget -O - | sudo tee /usr/local/bin/youtube-dl > /dev/null
sudo chmod a+x /usr/local/bin/youtube-dl
hash -r
share|improve this answer

You have to put double quotes (") before and after the URL of the video to make it work. I don't think it's a bug.

For example:

youtube-dl "<video-URL>"
share|improve this answer
This won't solve the issue. – David Foerster Feb 25 '15 at 17:08

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.