Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Something is waking my computer automatically from hibernate every morning. How can I find what program that is? Alternatively, how can I disable/prohibit all such wakeups?

(I presume it's through rtcwake or a similar mechanism.)

share|improve this question
up vote 1 down vote accepted

Nothing is automatically waking your computer up from hibernate. If your computer is in the hibernate state, it is actually powered off. The only way to turn it back on, is to push the power button.

If you mean from suspend, then most likely it is a configuration in your BIOS. There are no active programs running while the computer is in suspend mode. It's possible though, that your BIOS is configured to wake on LAN activity as well as keyboard or other events, and possibly something is making a network request to your computer, dialing the modem, or your cat is jumping onto the keyboard.

share|improve this answer
Oh something is definitely doing it automatically, since it wakes me up. :) And I did mean hibernation, not suspend. It is possible for RTC to run when the computer is turned off and in hibernation, you can search the web for [rtc hibernation] or something similar to see that. I'll have to double check that WOL isn't to blame, but I'm fairly sure I've turned it off. (No pets.) Thanks anyway. – otus Sep 29 '12 at 14:06
man rtcwake tells me that only some systems support wakeups from suspend-to-disk. Unfortunately mine seems to be one of them! – otus Sep 29 '12 at 14:15
Right, the RTC is one of the things that can do it. Your BIOS may be configured to turn the system on at a certain time, in which case the RTC would do this in the BIOS. However, unless you configured something to wake your computer at the time specified, it doesn't just do it. You either ran rtcwake to suspend and tell it to wake up, or something is configured in your BIOS. – dobey Sep 29 '12 at 14:21
Apparently Wake-on-Lan was on, so that may be to blame. I'm selecting your answer at least until I see if the symptoms vanish. – otus Sep 30 '12 at 4:54

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.