Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

A few days ago, I used my external hard disk (a 2TB Seagate) in order to transfer some files on Windows Vista. During that, I noticed some malfunctions on my system (it was running too slow, Windows Explorer crashed).

When Explorer crashed, file transportation stopped. I was afraid, but I tried to access my files and it seemed to be working. I tried to open a movie (from the external disk) but it couldn't load. I thought of restarting, but this took sooo long... So I unplugged the hard disk and at that time it managed to shut down. I logged on to Windows Vista but the hard disk couldn't be mounted. I plugged it but nothing happened. I unplugged it and I heard this specific sound that notifies that something has been unplugged.

I thought of logging to Ubuntu 10.04 and see what I can do. I plugged the hard disk, but I couldn't see it. I opened GParted but I couldn't see it either. I tried with Disc Utility and there it was! I tried to mount it but a got an error message stating that an error occured with Windows, there is a file (0,0) that has problem or something like that. It suggested to log into Windows and run chkdsk /f and reboot twice.

The thing is that I am somehow afraid to do so because I don't really know the impact on that. Plus I don't trust doing even a check on Vista...

I finally risked it and I typed

chkdsk/f

on a cmd. I cannot, however, actually run it because I don't have admin privileges. So from search I found chkdsk, I right cliked and selected “run as administrator”. It run but I got a message like NTFS file system. It should check at the coming restart.

At that point I am mistaken. I thought that f meant F but this is not the case here...

Does anyone have any suggestions and advice?


I've tried with Partition Magic Bootable CD but I couldn't get my HDD mounted.

At first I thought of running a disk health. My device was named "Unknown" and I got the message /dev/sdb failed: No such device

Then I tried with GParted but it couldn't find my HDD.

Finally I tried to mount it from a "mount utility" or sth like that but it couldn't be mounted.

The first time I tried I got an error

Run: Mount /dev/sdb 
Status: Finished with error(exit status 1)
udevil: error 64: unable to determine device fstype specify with -t

After that there was a list of all my drives. When I selected the external one I got the error message

Run: Mount /dev/sdb1
Status: Finished with error(exit status 18)
Failed to write lock '/dev/sdb1' : Resource temporalily unavailable
Error opening '/dev/sdb1':Resource temporalily unavailable
Failed to mount :Resource temporalily unavailable

The second time I tried to mount it I got a new error message

Run: Mount /dev/sdb
Status: Finished with error(exit status 1)
udevil: error 57: Cannot stat /dev/sdb: No such file or directory

Any ideas on what's going on?

share|improve this question
1  
It looks like either the filesystem or the disk is damaged. Do run chkdsk as recommended (you can do it on another Windows computer). Be prepared to have to replace the disk and restore your files from a backup. –  Gilles Sep 29 '12 at 13:02
    
Thank you very much for your answer! Running chkdsk is working on C,right? I want to access F, so is it proper to do so? What option should I do? f, r, i? The fact is that I don't have another windows computer... What do you mean, "replace the disk"? Could it be broken? And how am I going to backup, if I don;t have access? Sorry if I ask too many questions, but I beleive you understand my anxiety! –  Thanos Sep 29 '12 at 13:07
1  
I don't know how chkdsk works, I'm not a Windows expert. Try chkdsk /? (under Windows) to see a short description. It might be something like chkdsk f:. –  Gilles Sep 29 '12 at 13:14
    
I see...Can this be done in ubuntu? –  Thanos Sep 29 '12 at 13:20
2  
The problem might be shown in Ubuntu but this is a Windows problems. So fix this with Windows. I consider this off topic. –  Rinzwind Feb 7 at 17:57
show 3 more comments

closed as off-topic by Rinzwind, Seth, Alvar, Braiam, Avinash Raj Feb 8 at 12:36

This question appears to be off-topic. The users who voted to close gave these specific reasons:

  • "This describes a problem that can't be reproduced that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – Seth, Braiam, Avinash Raj
  • "This is not about Ubuntu. Questions about other Linux distributions can be asked on Unix & Linux, those about Windows on Super User, those about Apple products on Ask Different and generic programming questions on Stack Overflow." – Rinzwind, Alvar
If this question can be reworded to fit the rules in the help center, please edit the question.

2 Answers

when you don't want to restore lost datas, and simply only want that hard-disk works again ... you could (later) try this command for to make hard-disk new like fresh from factory - best over night (2 Tibi last a long time with dd like this) :

dd if=/dev/zero of=/dev/harddisk

harddisk stands for sda, sdb, or sdc whatever

When harddisk is external I would set it up on the side of it (upright). Then let run the dd-command over night.

when dd-command like above is breaking off too early (before last cylinder), then harddisk is broken and you could swap it (with warranty of manufactory for 2 years) against a new one at the manufactorer (not at trader).

share|improve this answer
add comment

Try to connect it to a Windows PC, go to:

Here's How:

Click on the Start button and then choose Control Panel.

Click on the System and Security link.

Note: If you're viewing the Large icons or Small icons view of Control Panel, you won't see this link so just click on the Administrative Tools icon.

In the System and Security window, click on the Administrative Tools heading located near the bottom of the window.

In the Administrative Tools window, double-click on the Computer Management icon.

When Computer Management opens, click on Disk Management on the left side of the window, located under Storage.

After a brief loading period, Disk Management should now appear on the right side of the Computer Management window.

Note: If you don't see Disk Management listed, you may need to click on the |> icon to the left of the Storage icon.

You can now partition a hard drive, format a hard drive, change a drive's letter, or do whatever else you need to do in Windows 7/8/8.1 Disk Management tool.

You will then find your hard drive, format it.

I´m afraid that you may have ruined the hard drive if you were formatting it with Parted Magic and you stopped it.

share|improve this answer
    
Answer is purely Windows and, to me, makes this off topic. –  Rinzwind Feb 7 at 17:56
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.