Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

How can I give my own command using mic.

I would like to give command like:

"Update system now"

So system will automatic run apt-get update

I've seen

but I get error :

$ @penreturns 06:34 PM ~
 > sudo apt-get install gnome-voice-control
[sudo] password for r00t: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package gnome-voice-control

My Details:

$ @penreturns 06:56 PM ~
uname -a; cat /etc/lsb-release; gnome-shell --version 
Linux penreturns 3.4.1-030401-generic #201206041411 SMP Mon Jun 4 18:12:24
UTC 2012 x86_64 x86_64 x86_64 GNU/Linux DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=12.04 
DISTRIB_CODENAME=precise
DISTRIB_DESCRIPTION="Ubuntu 12.04.1 LTS" 
GNOME Shell 3.5.4
$ @penreturns 06:56 PM ~

How do I start this project. What package do I need. What script do I need to learn.

share|improve this question

2 Answers 2

Voice Control for Ubuntu 12.04

Hi,

I think, Gnome-Voice-Control is not in the repositories ("Unable to locate package gnome-voice-control"). And as you can see here it is not longer developed.

If you would like to make and use your own voice commands ("Update system now") try Simon listens.

Simon Listens - Installation:

sudo add-apt-repository ppa:grasch-simon-listens/simon
sudo apt-get update
sudo apt-get install simon

In Simon, for example, you can record a command and link it to a bash-script doing what you want or link it to DBUS-commands. In this way it is very easy to create any voice command! I tried it and it works fine. The more you train your Speech-commands, the better it understands your commands after that.

Screenshot

Alternatively try VEDICS. But, until now, it can handle only one (?) command.

Best regards

share|improve this answer
    
has anyone ever gotten simon listens working on anything other than kde??? –  Joshua Robison May 4 '13 at 14:07

i tried to install simon on Elementary, and got this error:

The following packages have unmet dependencies: simon : Depends: libattica0 but it is not installable E: Unable to correct problems, you have held broken packages.

i downloaded and installed this: http://packages.ubuntu.com/lucid/amd64/libattica0/download

and that solved the issue :)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.