Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Using precise pangolin. I am trying to copy some folders from my portable hard drive to one of the partitions. The paste button is not working in the destination folder and whenever I am trying a drag-drop with my mouse, it says that I don't have permission to create there, albeit I have the root. Even the new folder button is not working. Help please. Dialogue box and Permission details attached.

share|improve this question
    
You may want to have a look at these questions: askubuntu.com/questions/47538/…, and e.g. askubuntu.com/questions/77655/… (and more) in case your partition is NTFS. –  Takkat Sep 29 '12 at 8:06
add comment

3 Answers 3

up vote 3 down vote accepted

Open a terminal and type

gksudo nautilus

A new nautilus browsing window will appear. Use it to copy and post the results.

share|improve this answer
4  
sudo nautilus is a bad idea, gksu nautilus is best. –  Tom Brossman Sep 29 '12 at 8:39
    
Hi, I thought gksu is for graphical applications and since nautilus is a file manager, we can open it with sudo. –  linuxandunix Sep 29 '12 at 9:32
1  
Nautilus is a graphical application. It involves the use of X, and it displays quite a few icons. Do you mind if I change it to gksudo? –  hexafraction Sep 30 '12 at 22:07
1  
I agree with @ObsessiveFOSS , 'gksudo' will be more appropriate. –  linuxandunix Oct 1 '12 at 3:37
    
You can try restarting nautilus askubuntu.com/a/489574/271328 –  harshjv Jun 29 at 12:52
add comment

I think I get your problem. Lets assume your destination folder is /home/user/MOVIES

If you are using your root account (Not recommend it) do the follwing

 chmod 777 /home/user/MOVIES  (You give all the permissions to your folder)
 cp /media/HARDDISK/ /home/user/MOVIES -R (You are copying all the content of your harddisk to you MOVIES folder)  
 if you have a special folder just specify it /media/HARDDISK/SPECIALFOLDER -R means recursive, you are going to copy what is on that folder)

If you check your destination folder only has access permissions, you can't write on it.

share|improve this answer
add comment

Each time I want to do this I have to Open a terminal and type gksudo nautilus to do the paste.

(I wonder myself if there any permanent option to do copy/paste.)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.