Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
How do I open Deja Dup as root?

I am using Ubuntu 12.04 LTS. I'm trying to setup Deja Dup to backup the files for several users (/home) and /etc but as it runs as myself, there are many files it cannot read and therefore cannot backup.

I want to try running Deja Dup as root as then it should be able to read and backup all files.

I've seen some other info about how to set up a particular App to run as root, so I guess I should try that.

share|improve this question

marked as duplicate by jokerdino, RolandiXor, Eliah Kagan, January, Mitch Sep 29 '12 at 7:43

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Thanks jokerdino, very helpful. I'll try that. I assume I should keep my user backups in a different folder to the root backups? –  Chris Good Sep 29 '12 at 6:05
    
My backup when run as root (to a different folder than my backup run not as root) worked with no errors, so now I'm happy! Many Thanks! How do I flag this question as answered? It doesn't say how in the Ask Ubuntu faq, or are questions only closed if they are inappropriate? –  Chris Good Sep 29 '12 at 6:46
    
Good to know that it worked without any problems. And don't worry about closing this question. It will be handled. –  jokerdino Sep 29 '12 at 7:15
add comment

2 Answers 2

To Enable root login, open Terminal and enter following commands:

sudo passwd root
sudo sh -c 'echo "greeter-show-manual-login=true" >> /etc/lightdm/lightdm.conf'

Now Restart your lightdm and login as root.

sudo service lightdm restart

enter image description here

share|improve this answer
    
Thanks maythux. Good to know. –  Chris Good Sep 29 '12 at 6:48
    
you are welcome if this solve your problem mark as accept to help others –  user61928 Sep 29 '12 at 6:52
add comment

Once you've unlocked the root account, you have to edit /etc/lightdm/users.conf and change minimum-uid to 0.

share|improve this answer
    
Thanks sly. As it seems the accepted thing to do is not login as root, and I no longer need to thanks to jokerdino's help, I won't use this unless I need to in future. –  Chris Good Sep 29 '12 at 6:39
    
No problem. Just providing the answer for other people that may have this question. –  Sly Sep 29 '12 at 6:43
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.