Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running Ubuntu 12.04 with zfsonlinux and transmission-daemon.

The issues:

sporadic Bad File Descriptor and Piece #xxx is corrupt errors.

After I recheck the torrent, everything seems fine. That happens only when downloading: once it's in seeding mode. This only happens after the torrent client has been running for some time.

I installed zfsonlinux from the official stable PPA. I previously tried running transmission-daemon from the Ubuntu repository, but since I've switched to building the latest transmission from source with the latest libevent (all stable) - same thing.

I've seen bug reports for that issue, but none of them seem to have a solution.

How can I fix these errors or at least understand where they come from and what I can do to rectify the issue?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

It turned out transmission-daemon has a bug, after verify it can show a torrent as 100%, but still fail when trying to read it. What makes the issue worse is that it reports Bad file descriptor on downloading torrents, not the bad one. After strace-ing it, I figured I always got bad file descriptor on the same file, no matter what it reported, so I removed that torrent and everything works fine. There's more information on the transmission trac page.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.