Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

How can i mount a NTFS partition, which has german umlaute (ä, ö, ü) in the filenames. I'm using the following mount command:

mount -t ntfs-3g UUID=5A9098309098149B /local/data -olocale=de_DE.UTF-8
share|improve this question
3  
Have you tried without the -olocale ? Which error did you get ? According to man mount.ntfs the use of -olocale is discouraged as it leads to files with untranslatable chars to not be visible. –  João Pinto Dec 30 '10 at 15:16
2  
Umlauts work fine with my NTFS partitions without adding any special mount options (en_US.UTF-8 based Ubuntu). –  htorque Dec 30 '10 at 18:00
    
i tried without the locale option, but when i do a 'ls' on the NTFS mount point i get strange chars instead of the german umlaute). Do i need some special package installed? Any special fonts? –  Andreas Roth Dec 31 '10 at 12:44
    
How about adding "-o iocharset=utf8" (and removing the -olocale)? (Works for my OS X share (-t smbfs) and Norwegian filenames, don't know about NTFS.) –  j-g-faustus Jan 5 '11 at 21:30
    
i tried this too, but it didn't work. –  Andreas Roth Jan 8 '11 at 8:09

3 Answers 3

up vote 0 down vote accepted

Of the supposed options for mount, neither nls nor iocharset will help, as they are not even defined for NTFS. Consult the man page man mount.ntfs. Also, the default system locale is specified in /etc/default/locale on Ubuntu systems. You have not told us what locale you use, is it really en_US? That would be bad and so ’90s, as UTF-8 ought to be the standard by now.

Under a UTF-8 locale, a simple mount should do it:

mount -t ntfs UUID=5A9098309098149B /local/data

Other than that, I cannot help. It works for me.

share|improve this answer
    
I switched my installation from KDE to GNOME and now it seems to work fine. I assume in my KDE installation some packages or some settings are missing. I need to narrow this issue down further. But the initial problem is solved for now. In the end i did not need to specify the locale mount option at all. –  Andreas Roth Jan 8 '11 at 8:11
    
This is incorrect, both nls and iocharset are defined for NTFS according to man mount. Strange though that they are not mentioned in man mount.ntfs. Perhaps a documentation bug? –  Andreas J. Dec 9 '13 at 7:37

The locale locale=de_DE.UTF-8 in the mount option it's ok, you need then to change the system locale as well

/etc/profile.d/lang.sh 

export LANG=de_DE.UTF-8

and restart the PC (or re-source the profile)

share|improve this answer
    
but i don't want the german locale used at all (the PC is set up to en_US). i only what the NTFS partition to be treated german, so i get readable filenames (with the german umlaute). –  Andreas Roth Dec 30 '10 at 14:26
    
Either way i tried your suggestion, but it does not work. I also install the package language-support-de (to be on the safe side), but this didn't help. –  Andreas Roth Dec 30 '10 at 14:51
    
-1 changing the system locale has no effect on the ntfs-3g mount options, also using locate= is discouraged (according to man mount.ntfs) –  João Pinto Dec 30 '10 at 15:14
    
I noticed that setting the system locale does not work, but i haven't noticed any changes when i specify different locale options in the mount command. I wonder how is it suppose to work? –  Andreas Roth Dec 30 '10 at 18:05

You can try to add option nls=utf8.

mount -t ntfs-3g UUID=5A9098309098149B /local/data -o nls=utf8
share|improve this answer
    
i found this hint somewhere in the internet before and this didn't work too. –  Andreas Roth Dec 30 '10 at 18:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.