Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

2x Xeon E5620 . 16 Cores altogether. /proc/cpuinfo shows cache is only @ 4096kb

According to intel this should have 12MB of "smart cache". Doing searched for E5620 and CPUinfo shows the correct number:

cache size : 12288 KB

However mine shows this:

processor       : 15
v    endor_id       : GenuineIntel
cpu family      : 6
model           : 44
model name      : Intel(R) Xeon(R) CPU           E5620  @ 2.40GHz
stepping        : 2
microcode       : 0x1
cpu MHz         : 2400.104
cache size      : 4096 KB
fpu             : yes
fpu_exception   : yes
cpuid level     : 11
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36 clflush mmx         
bogomips        : 4800.20
clflush size    : 64
cache_alignment : 64
address sizes   : 40 bits physical, 48 bits virtual

this is under a KVM kernel as a baremetal guest.

lscpu shows this:

Architecture:          x86_64
CPU op-mode(s):        32-bit, 64-bit
Byte Order:            Little Endian
CPU(s):                16
On-line CPU(s) list:   0-15
Thread(s) per core:    1
Core(s) per socket:    1
Socket(s):             16
NUMA node(s):          1
Vendor ID:             GenuineIntel
CPU family:            6
Model:                 44
Stepping:              2
CPU MHz:               2400.104
BogoMIPS:              4800.20
Hypervisor vendor:     KVM
Virtualization type:   full
L1d cache:             32K
L1i cache:             32K
L2 cache:              4096K
NUMA node0 CPU(s):     0-15

KVM seems to be stealing some cpu cache. why is this?

.

share|improve this question

migrated from serverfault.com Sep 28 '12 at 22:05

This question came from our site for professional system and network administrators.

add comment

1 Answer

For portability/compatibility reasons, by default KVM only emulates a "standard" CPU with a subset of the available host CPU features. Apart from the reduced cache, you can also see from the flags that none of the SSE features, for example, are available.

To provide the full set of host CPU features to guests, add the -cpu host option to your KVM/QEMU command line.

For more information, see Tuning KVM

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.