Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When autohide is toggled on, the unity launcher won't show up unless I press the super key. This problem is present in Unity and Unity 2D. The launcher worked properly before but for some reason it isn't working as it should any longer.

share|improve this question

closed as off topic by Takkat, Eliah Kagan, Mitch, LnxSlck, Tom Brossman Oct 2 '12 at 21:58

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Did you upgrade Nvidia drivers? See askubuntu.com/a/195105 –  Takkat Oct 1 '12 at 14:38
    
I think I'm running the latest driver; 304.51 –  Vagrant232 Oct 2 '12 at 9:20
    
You should then downgrade the driver as recommended in the accepted answer to the question I linked above. Still because its a bug we need to close your question according to our FAQ. –  Takkat Oct 2 '12 at 10:32
    
Thank you for your assistance. I'm sorry I posted this, I wasn't aware it's a bug I thought I did something to disable the launcher's autohide mechanism. –  Vagrant232 Oct 2 '12 at 10:41
    
Nothing to be sorry of - posting this was good. It will lead people to the right direction! –  Takkat Oct 2 '12 at 10:45

1 Answer 1

It's most likely to do with the sensitivity of the reveal and has been a problem for many people since they took the autohide dodge feature out. The problem is worse on touchpads because the amount and speed of travel is less.

Finally, there appears to be a bug report that is being taken seriously: https://bugs.launchpad.net/unity/+bug/931982

There were bug reports previously but they were closed out after some minor adjustments were made. The adjustments didn't seem to make much difference.

Set the reveal sensitivity to maximum (system settings -> appearance -> behaviour tab) and if this doesn't work increase the speed of the mouse.

If it still doesn't work and you're on a touchpad try attaching a mouse set to a high speed and see if that works. (for testing, mainly)

You say you've changed things using Ubuntu tweak. I guess it's possible a setting has caused a conflict or had an unwanted action in this case. Try resetting Unity to all the defaults and see if the problem goes away:

unity --reset

Warning! This will undo all the changes you've made to unity - Launcher size, behaviour, colours, everything.

share|improve this answer
    
Thank you for your reply! I'm not using a touchpad and I've increased the sensitivity of both the launcher and the mouse to the maximum but the Launcher still won't show up unless I press the super key. If it helps I have Ubuntu Tweak installed and have set the top left corner to trigger a window overview mode (just like Gnome 3's activity overview). If I hover my mouse over the top left corner, both the launcher and the windows would appear, however the launcher won't appear if I placed the mouse anywhere else even though I set it to appear at the left side and not the top left corner. –  Vagrant232 Sep 28 '12 at 22:18
    
OK, I've tried that in Ubuntu tweak and it didn't stop the Launcher reveal –  fabricator4 Sep 28 '12 at 23:06
    
If a changed setting in Tweak is causing this you could try resetting everything to defaults and being very careful adding tweaks back into the system. –  fabricator4 Sep 28 '12 at 23:12
    
I've added an option to my answer for resetting Unity completely –  fabricator4 Sep 28 '12 at 23:19
    
I already tried unity --reset before and It did me no good. Actually I've had ubuntu tweak installed for quite a while and it didn't cause conflict before. I was just pointing that it's probably not a mouse sensitivity issue. –  Vagrant232 Sep 29 '12 at 7:42

Not the answer you're looking for? Browse other questions tagged or ask your own question.