Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a netbook with included 3G mobile broadband card (Huawei E620). I have configured the broadband network connection in the Network Manager and it works perfectly.

However since Maverick upgrade, a window appears just after login I asking for the SIMcard PIN. This happens every time I log in and did not happen with Lucid. Note that the PIN is stored in the configuration of the mobile broadband connection and Lucid was satisfied with that.

Is there a way to prevent this request or, at least, to have the system rember the PIN and stop ansking for it?

If it may be useful, the broadband network connection is configured as not being available for other users. Also, I would like to keep the SIMcard asking for the PIN; only I do not want to insert it manually at login.

share|improve this question
    
Have you ever tried to edit connections and then delete the above mentioned connection? –  desgua Mar 27 '11 at 4:48
    
I managed to solve in a subobtimal way. I moved the card to a phone and disabled the PIN request, then moved back the card to my PC. This is not as secure as I would like, but it removes the annoying problem. –  Giacomo Verticale Mar 27 '11 at 8:43
add comment

2 Answers 2

up vote 1 down vote accepted

I think this is a known bug in the network-manager package and was fixed in Version 0.9.2. The patch is not yet (December 2011) integrated in the mainline repositories.

share|improve this answer
add comment

I don't know if this will work or not but try adding the word "auto" in front of the name of your 3G network. I had a similar problem with my WPA wireless connection on autoconnect. Changing my network name, "Vidnet", to "auto Vidnet" fixed the issue with me.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.