Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed LAMP and WordPress on my system a week ago. Since I couldn't create Child Themes in WordPress and work with PHP folders for my other projects collocated in var/www without using Nautilus I wanted to solve the permissions issue.

I hoped to bring a solution carrying out the commands on this page for my WordPress folder: http://wiki.apache.org/httpd/FileSystemPermissions.

This allowed me to play with any file in the folder like creating and modifying .css files through WP Admin, etc. But after a restart I discovered that I can't change DNS settings of my network connections in the list anymore because it is asking me the root password and even though I enter the password it doesn't let me do the action giving "insufficient privileges" error.

Can you help me correct the mistake I possibily made during the configuration and, maybe, configure again the permission and ownership settings for var/www/somefolder as it is adviced to be configured under general circumstances?

Thanks in advance!

share|improve this question
add comment

2 Answers

I fear, you can't reverse the change unless you saved the permission settings somewhere.

I recommend this, Install the same softwares in another machine, check the permissions there, copy them and use the same permissions for your machine to correct the errors.

share|improve this answer
add comment

Assuming you ran the commands in the link you gave, simply run

sudo -R chown www-data:www-data /var/www

You should know that by default, ubuntu uses www-data as the apache (and other http servers) user/group.

See also:

https://help.ubuntu.com/community/ApacheMySQLPHP

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.