Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Background:

I have a desktop computer running Ubuntu 12.04. I have installed DRBL to handle DHCP server and Clonezilla Server. I have a network card in my desktop with 2 ports in it. These 2 ports are bonded together and are used by DRBL. There is a 3rd port integrated in the motherboard. I want to use this 3rd port for internet. DRBL knows that this is set for internet. EDIT: "Ubuntu Network-Manager has stopped recognising the connections (device not managed)." - I have now uninstalled Network-Manager. It use to say that eth1 was default (first port in the network card) I want eth0 to be default as that is the Internet port.

Question:

How do I make eth0 as the default port without using Network-Manager?

share|improve this question

migrated from serverfault.com Sep 28 '12 at 14:29

This question came from our site for professional system and network administrators.

1 Answer 1

up vote 3 down vote accepted

The way to use network manager for default network assignment is by checking the 'Use this connection only for resources on its network' option in editing IPv4 routes on all connections you do NOT want to be the default.

To do this without Network manager simply edit connections that you don't want to be default and add the following at the end of each corresponding file in /etc/NetworkManager/system-connections/YourConnection

never-default=true

this line should be added under IPv4 section.

NOTE: Replace YourConnection with the corresponding Connection name. You can see available options via

ls /etc/NetworkManager/system-connections/

share|improve this answer
    
Please see the Edits, thanks for the answer! –  No1_Melman Oct 1 '12 at 10:38
    
So would YourConnection be like eth0 if thats my internet port? –  No1_Melman Oct 1 '12 at 12:09
    
i don't have network-manager –  No1_Melman Oct 1 '12 at 12:15
    
genius thanks for your answer - perfect! –  No1_Melman Oct 1 '12 at 13:00
    
I have found in NetworkManager.conf that has a line like no-auto-connection=[mac addresses] so i wonder if i can have auto-connection=[mac address] ?? –  No1_Melman Oct 1 '12 at 13:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.