Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

On Ubuntu's Web Page, in the Certified hardware section, it is listed Lenovo. So I decided to buy a ThinkPad from Lenovo. Just one month after I bought the notebook, the battery got a problem and it does not charge anymore. Now Lenovo won't give me any support because I am using Ubuntu. Lenovo says they will give support only for Windows users because their tools runs on Windows. They refused to change my battery before running the Windows based test. What should I do?

share|improve this question

closed as too localized by belacqua, Ringtail, Tom Brossman, Takkat, con-f-use Nov 3 '12 at 11:45

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

Backing up your stuff and putting Windows on it may be your only solution. – belacqua Nov 1 '12 at 15:38
You don't have to accept Lenovo's decision, you have legal rights you can exercise under your warranty/consumer protection laws (varies by country, find & read them). I go through this 1-2x/year and always prevail. Send them a proper business letter with your demand. Just make sure it really is a hardware problem! Some people prefer to avoid the conflict entirely and swap the factory drive with another prior to first boot. That works too, but costs more. Good luck. – Tom Brossman Nov 2 '12 at 6:18

I turned the computer on using only the battery. Then it gives the message that it is critically low and don't boot. I did it again, but this time I entered the Bios. I waited there until the battery was completely discharged. Then I plugged the AC Adapter and booted normally. Now the battery is charging again.

share|improve this answer
That's strange. Glad you figured it out and don't have to struggle with the support :-) – André Stannek Oct 4 '12 at 1:32

This sounds like a hardware failure to me. Try charging it while it is powered off. If that doesn't work it definitely has nothing to do with Ubuntu.

Don't know how it is in Brazil but I would say they can't force you to have Windows installed to replace obviously broken hardware and refusing to do so doesn't sound like Lenovo at all. You should insist on them to fix this. If they need Windows to fix it, I think it's their job to swap the hard drive and install it themselves.

share|improve this answer
It doesn't get any charge at all, even when charging while powered off. :( – LEo Sep 28 '12 at 17:59
Can you easily remove the hard drive yourself? Don't know the edge series that well. My Lenovo dealer accepts Thinkpads without hard drive for fixing. – André Stannek Sep 28 '12 at 18:58
They were supposed to have in situ assistance, but they are not coming unless I run this Windows test before. I've offered to send the battery by mail, so they can make the test themselves, but they said they don't work this way. – LEo Sep 28 '12 at 19:11

I have had the same issue. After much fooling around, I discovered that the problem seems to be in a faulty locking switch. At times the problem is solved when I take the battery out and sharply close the locking switch. Other times in the battery component of Lenovo, it means resetting the battery under Battery Management.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.