Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
How to set the monitor to its native resolution which is not listed in the resolutions list?
Screen resolution stuck at 1024x768

I don't know if there is already a question like that but after my last update (Update manager) when i logged in Ubuntu my resolution was set to 1024/768 and there is no option at displays to change it to another.when i use the command -> sudo apt-get install nvidia-current the output at terminal is that :

sudo apt-get install nvidia-current

Reading package lists... Done
Building dependency tree       
Reading state information... Done
nvidia-current is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.

I am noob with Ubuntu and i would like some help to fix this problem. Thanks in advance for your help

share|improve this question

marked as duplicate by Javier Rivera, Tom Brossman, SirCharlo, hexafraction, Mik Sep 28 '12 at 21:07

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
On a console type glxinfo | grep direct add the output to your question –  LnxSlck Sep 28 '12 at 11:30
    
Xlib: extension "GLX" missing on display ":0". Xlib: extension "GLX" missing on display ":0". Xlib: extension "GLX" missing on display ":0". Xlib: extension "GLX" missing on display ":0". Xlib: extension "GLX" missing on display ":0". Error: couldn't find RGB GLX visual or fbconfig Xlib: extension "GLX" missing on display ":0". Xlib: extension "GLX" missing on display ":0". Xlib: extension "GLX" missing on display ":0". Xlib: extension "GLX" missing on display ":0". Xlib: extension "GLX" missing on display ":0". –  Emilios.K Sep 28 '12 at 11:46
    
check this question [askubuntu.com/questions/19954/… [1]: askubuntu.com/questions/19954/… –  user91632 Sep 28 '12 at 11:46

1 Answer 1

remove the xorg config file & reboot.

Type in

sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.back.

Then reboot the system sudo reboot now

If that doesn't solve the problem or cause any other thing, revert back using

sudo mv /etc/X11/xorg.conf.backup /etc/X11/xorg.conf

share|improve this answer
    
the answer at the first command: mv: cannot stat `/etc/X11/xorg.conf': No such file or directory –  Emilios.K Sep 28 '12 at 11:40
    
and something else, when i try to open nvidia x server settings i get the message : You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run nvidia-xconfig as root), and restart the X server. –  Emilios.K Sep 28 '12 at 11:51
    
execute sudo nvidia-xconfig, try to change resolution and reboot. –  Web-E Sep 28 '12 at 11:59
    
The output of xrandr: xrandr: Failed to get size of gamma for output default Screen 0: minimum 640 x 480, current 1024 x 768, maximum 1680 x 1050 default connected 1024x768+0+0 0mm x 0mm 1024x768 61.0* 800x600 61.0 640x480 60.0 1680x1050_60.00 60.0 1680x105_60.00 (0x73) 146.2MHz h: width 1680 start 1784 end 1960 total 2240 skew 0 clock 65.3KHz v: height 1050 start 1053 end 1059 total 1089 clock 60.0Hz –  Emilios.K Sep 28 '12 at 12:40
    
And the output of command xrandr --addmode default 1680x1050_60.00 ekeinos@ekeinos-OEM:~$ xrandr --addmode default 1680x1050_60.00 xrandr: Failed to get size of gamma for output default –  Emilios.K Sep 28 '12 at 12:41

Not the answer you're looking for? Browse other questions tagged or ask your own question.