Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

It seems that panel shadow is somehow hardcoded in KDE 4 and devs do not have any plans to change it and/or make it customizable. So, what I'm actually asking is some kind of hack (if there is any) which will remove the shadow of the panel in KDE 4.x completely (but without need to disable all desktop effects in the process).

Possible application: When a user wants a completely transparent panel, no top/bottom borders at all, the shadow is completely out of place and destroys the experience.

As requested by user26687, the image shows the panel shadow.

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

Could you

Could you show an example picture ?

How did you make/test it ?

At here

Editing the neon-plasma-glow-by-FRUiT plasma/desktop theme /widgets/panel-background.svgz picture file. Disabling the object fill -> full transparent panel.

enter image description here

I can't see panel shadows.

Take 2

KDE documents:

From the Kubuntuforums:

The original Air theme (1), Transparent (2), Without the shadow (3).

enter image description here

1) Copying the default plasma theme (Air) from the /usr/share/kde4/apps/desktoptheme/default to the ~/.kde/share/apps/desktoptheme/transparent .

2) Editing the ~/.kde/share/apps/desktoptheme/transparent/metadata.desktop. Changing the theme name to the Transparent

3) Editing the ~/.kde/share/apps/desktoptheme/transparent/translucent/widgets/panel-background.svgz

enter image description here

4) Changing the Fill from the Linear gradient to the No Paint. The result is a transparent panel with the shadow (2)

enter image description here

5) Removing the shadow. Picking the shadow elements and deleting them. The result is a transparent panel without the shadow (3)

enter image description here

6) If you want to use the partial/mini panel edit the mini elements. Change the Fill to the No Paint.

enter image description here

The panel svg image is a bit bare....

enter image description here

share|improve this answer
    
Thanks for your suggestions. Still, I do see the shadow, as the image shows (I used the same theme you mentioned). Note: if I disable desktop effects and enable them again, the shadow does disappear. But if I change desktop theme, the shadow appears again. –  Meho R. Sep 29 '12 at 19:53
    
Thanks for your effort, but the result is still the same (tested on Netrunner, which is basically Kubuntu, with prop nVidia graphics driver, and Debian with nouveau graphics driver, both with KDE 4.8.5). Also, changing panel-background.svgz from "transparent/translucent/widgets" dir doesn't have any visible effect whatsoever; only the one in "transparent/widgets" does. Note that I emptied cache (~/.kde/cache) prior to applying transparent desktop theme every time, just in case. Will test it some more. –  Meho R. Oct 1 '12 at 16:51
    
OK, killing plasma-desktop might just make the difference. Will see if it holds water :-) –  Meho R. Oct 1 '12 at 17:38
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.