Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I run this script https://help.ubuntu.com/community/MigrateWubi

and reveiced a message :

Found Ubuntu 12.04.1 LTS (12.04) on /dev/sda7
...
 migration completed successfully.

Then i restarted computer and choose ubuntu from 2 lines

Windows 
Ubuntu

. But i don't see what changed, if i am on a partition with Ubuntu or Wubi .

@ubuntu:~/sudo fdisk -l

/dev/sda1   *          63   167782859    83891398+   7  HPFS/NTFS/exFAT
/dev/sda2       167782860   976768064   404492602+   5  Extended
/dev/sda5       167782923   284337032    58277055    7  HPFS/NTFS/exFAT
/dev/sda6       587224008   669566016    41171004+   7  HPFS/NTFS/exFAT
/dev/sda7       284340224   587223039   151441408   83  Linux
/dev/sda8       669569024   710529023    20480000   82  Linux swap / Solaris

EDIT: I download proposed pack from issue 1.

share|improve this question

2 Answers 2

up vote 1 down vote accepted

In a terminal (ctrl-alt-T), type

mount

If you see that your root directory ("/") is mounted on something like "/dev/sda7", then your installation is on that partition. If in doubt, post the result of that command here.

If mount shows something like

/dev/loop0 /

it means that you did not manage to install the grub loader correctly, and you still use the Windows loader to get to the WUBI installation.

Follow these instructions to install grub.

  1. Make sure that on /dev/sda7 you have the copy of the system (you can use the LiveCD to boot the system that is installed on /dev/sda7 to see whether it was installed correctly)

  2. Given that your new system is mounted in WUBI /dev/sda7 on /media/ce0c18e4-3d5d-466b-ba64-e19f1b129957, run

    sudo grub-install –-root-directory=/media/ce0c18e4-3d5d-466b-ba64-e19f1b129957 /dev/sda
    

This should install Grub to /dev/sda and allow you to boot in Ubuntu.

share|improve this answer
    
i installed it on /dev/sda7 . This is result when i run "mount" : gist.github.com/d76146ca58d7d570ebe5 –  meotimdihia Sep 28 '12 at 10:26
    
Means that you are still running WUBI. You did not manage to install grub correctly. –  January Sep 28 '12 at 10:30
    
Did wubi-move-2.2.sh help me to install it ? –  meotimdihia Sep 28 '12 at 10:32
    
I have updated the answer. –  January Sep 28 '12 at 10:35
    
I get error More than one install_devices? when run sudo grub-install –root-directory=/media/ce0c18e4-3d5d-466b-ba64-e19f1b129957 /dev/sda –  meotimdihia Sep 28 '12 at 10:41

If you used --no-bootloader when you ran the script, you can boot the migrated install from the Wubi grub menu. I am assuming this is what you did, because otherwise it would have install Grub2's bootloader to /dev/sda and the first thing you would have seen was a grub menu (not the Windows boot manager, which you described).

You'll see the migrated install around the 4th option in the menu, after Previous Linux versions. Boot it from there before trying to install Grub to the bootloader. Then you can confirm it's working and just install grub from there: sudo grub-install /dev/sda

If you don't see the Wubi grub menu, then say so (it sometimes happens and setting the grub graphics mode to text in the wubi install will fix this).

Here's an example of my Wubi grub menu with the migrated install as the 4th entry (not the highlighted entry): enter image description here

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.