Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I search all around the internet till the 6th page of result on google with very precise search, but I can't figure how I can do that.

I'm working with last updated ubuntu 12.04 and gnome shell, and I wonder how I can REMOVE and I say remove not clear or avoid feeding but remove completly the "recent item" bookmark you can see in the standard save windows of gnome shell here's a picture (in french it's "Récemment utilisés"):

Sorry not enought point to post image to see what I talk about, just do that:
-open gedit
-type anything
-save your file
-Now that windows got a "recent item" and I want it DOWN

I cannot reward point, but I would if I could for the guy finding a solution, and a bonus point if you find a way to remove it every where it appears in gnome shell.

Thank you for time.

Antoine

share|improve this question
add comment

1 Answer 1

up vote 0 down vote accepted

I've had a look around, but I can't obviously find a solution. Since you are running 12.04, this is presumably a GTK3 file chooser dialog.

The GTK3 global settings (/etc/gtk-3.0/settings.ini or $HOME/.config/gtk-3.0/settings.ini) should understand keys gtk-recent-files-limit and gtk-recent-files-max-age, which will allow you to empty the list (but this will only empty the list, not remove it as you ask for).

Gedit has a gsettings key org.gnome.gedit.preferences.ui max-recents but I think this only controls the number of recent files in the File menu. The gsettings schema for the GTK file dialog does not appear to contain any useful option.

The same issue is discussed here, which suggests recompiling GTK (note this is for GTK2 and might be a bit different for GTK3) with the behaviour disabled - I can't find any simpler solution for the moment.

share|improve this answer
    
All right I'll try it maybe, if I find enought motivation. thank you for the precision At least now I know where the problem precisely –  Kiwy Sep 28 '12 at 10:36
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.