Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want to install Trinity (the fork of KDE 3.x) on Ubuntu 12.04. I tried adding the PPA and doing sudo apt-get install kubuntu-default-settings-trinity kubuntu-desktop-trinity, but I got an error:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
kubuntu-desktop-trinity : Depends: ark-trinity but it is not going to be installed
                           Depends: kcontrol-trinity but it is not going to be installed
                           Depends: kcron-trinity but it is not going to be installed
                           Depends: tde-style-qtcurve-trinity but it is not going to be installed
                           Depends: tde-systemsettings-trinity but it is not going to be installed
                           Depends: tdeadmin-kfile-plugins-trinity but it is not going to be installed
                           Depends: tdebase-kio-plugins-trinity but it is not going to be installed
                           Depends: tdegraphics-kfile-plugins-trinity but it is not going to be installed
                           Depends: tdemultimedia-kfile-plugins-trinity but it is not going to be installed
                           Depends: tdemultimedia-kio-plugins-trinity but it is not going to be installed
                           Depends: tdenetwork-filesharing-trinity but it is not going to be installed
                           Depends: tdenetwork-kfile-plugins-trinity but it is not going to be installed
                           Depends: kdepasswd-trinity but it is not going to be installed
                           Depends: tdeprint-trinity but it is not going to be installed
                           Depends: kdesktop-trinity but it is not going to be installed
                           Depends: tdm-trinity but it is not going to be installed
                           Depends: kdnssd-trinity but it is not going to be installed
                           Depends: kghostview-trinity but it is not going to be installed
                           Depends: khelpcenter-trinity but it is not going to be installed
                           Depends: kicker-trinity but it is not going to be installed
                           Depends: kio-locate-trinity but it is not going to be installed
                           Depends: kmenuedit-trinity but it is not going to be installed
                           Depends: kmix-trinity but it is not going to be installed
                           Depends: knetworkconf-trinity but it is not going to be installed
                           Depends: konq-plugins-trinity but it is not going to be installed
                           Depends: konsole-trinity but it is not going to be installed
                           Depends: kpdf-trinity but it is not going to be installed
                           Depends: ksmserver-trinity but it is not going to be installed
                           Depends: ksnapshot-trinity but it is not going to be installed
                           Depends: ksvg-trinity but it is not going to be installed
                           Depends: ksystemlog-trinity but it is not going to be installed
                           Depends: twin-trinity but it is not going to be installed
                           Depends: twin-style-crystal-trinity but it is not going to be installed
                           Depends: libarts1-akode-trinity but it is not going to be installed
                           Depends: ksplash-engine-moodin-trinity but it is not going to be installed
                           Depends: sudo-trinity but it is not installable
                           Depends: qca-tls but it is not installable
                           Depends: kdbusnotification-trinity but it is not going to be installed
                           Depends: gtk-qt-engine-trinity but it is not going to be installed
                           Depends: qt4-tqt-theme-engine but it is not going to be installed
                           Recommends: kio-apt-trinity but it is not going to be installed
                           Recommends: tde-guidance-powermanager-trinity but it is not going to be installed
                           Recommends: adept-trinity but it is not going to be installed
                           Recommends: akregator-trinity but it is not going to be installed
                           Recommends: amarok-trinity but it is not going to be installed
                           Recommends: bluez-utils but it is not going to be installed
                           Recommends: bogofilter but it is not going to be installed
                           Recommends: cdparanoia but it is not going to be installed
                           Recommends: cdrdao but it is not going to be installed
                           Recommends: cups-pdf but it is not going to be installed
                           Recommends: desktop-effects-tde-trinity but it is not going to be installed
                           Recommends: digikam-trinity but it is not going to be installed
                           Recommends: foo2zjs but it is not going to be installed
                           Recommends: foomatic-db-gutenprint but it is not going to be installed
                           Recommends: gwenview-trinity but it is not going to be installed
                           Recommends: hpijs-ppds but it is not going to be installed
                           Recommends: ijsgutenprint but it is not going to be installed
                           Recommends: k3b-trinity but it is not going to be installed
                           Recommends: kaddressbook-trinity but it is not going to be installed
                           Recommends: kaffeine-trinity but it is not going to be installed
                           Recommends: kamera-trinity but it is not going to be installed
                           Recommends: karm-trinity but it is not going to be installed
                           Recommends: katapult-trinity but it is not going to be installed
                           Recommends: kate-trinity but it is not going to be installed
                           Recommends: kbstate-trinity but it is not going to be installed
                           Recommends: tdepim-kio-plugins-trinity but it is not going to be installed
                           Recommends: tdepim-wizards-trinity but it is not going to be installed
                           Recommends: tdesudo-trinity but it is not going to be installed
                           Recommends: keep-trinity but it is not going to be installed
                           Recommends: kfind-trinity but it is not going to be installed
                           Recommends: kio-umountwrapper-trinity but it is not going to be installed
                           Recommends: kipi-plugins-trinity but it is not going to be installed
                           Recommends: klipper-trinity but it is not going to be installed
                           Recommends: kmag-trinity but it is not going to be installed
                           Recommends: kmail-trinity but it is not going to be installed
                           Recommends: kmailcvt-trinity but it is not going to be installed
                           Recommends: kmilo-trinity but it is not going to be installed
                           Recommends: kmousetool-trinity but it is not going to be installed
                           Recommends: kmplayer-konq-plugins-trinity but it is not going to be installed
                           Recommends: knotes-trinity but it is not going to be installed
                           Recommends: konqueror-trinity but it is not going to be installed
                           Recommends: konqueror-nsplugins-trinity but it is not going to be installed
                           Recommends: kontact-trinity but it is not going to be installed
                           Recommends: konversation-trinity but it is not going to be installed
                           Recommends: kooka-trinity but it is not going to be installed
                           Recommends: kopete-trinity but it is not going to be installed
                           Recommends: korganizer-trinity but it is not going to be installed
                           Recommends: kpf-trinity but it is not going to be installed
                           Recommends: kppp-trinity but it is not going to be installed
                           Recommends: krdc-trinity but it is not going to be installed
                           Recommends: krfb-trinity but it is not going to be installed
                           Recommends: kscreensaver-trinity but it is not going to be installed
                           Recommends: ksysguard-trinity but it is not going to be installed
                           Recommends: ktorrent-trinity but it is not going to be installed
                           Recommends: kubuntu-docs-trinity but it is not installable
                           Recommends: kubuntu-konqueror-shortcuts-trinity but it is not installable
                           Recommends: kvkbd-trinity but it is not going to be installed
                           Recommends: kwalletmanager-trinity but it is not going to be installed
                           Recommends: landscape-client but it is not going to be installed
                           Recommends: min12xxw but it is not going to be installed
                           Recommends: networkstatus-trinity but it is not installable
                           Recommends: openoffice.org-calc but it is not going to be installed
                           Recommends: openoffice.org-impress but it is not going to be installed
                           Recommends: openoffice.org-trinity but it is not installable
                           Recommends: openoffice.org-writer but it is not going to be installed
                           Recommends: pinentry-qt
                           Recommends: powernowd but it is not installable
                           Recommends: pxljr but it is not going to be installed
                           Recommends: rdesktop but it is not going to be installed
                           Recommends: scim-bridge-agent but it is not going to be installed
                           Recommends: scim-bridge-client-qt but it is not going to be installed
                           Recommends: scim-qtimm but it is not installable
                           Recommends: skim but it is not installable
                           Recommends: speedcrunch but it is not going to be installed
                           Recommends: splix but it is not going to be installed
                           Recommends: strigi-daemon but it is not going to be installed
                           Recommends: system-config-printer-tde-trinity but it is not installable
                           Recommends: ttf-arabeyes
                           Recommends: ttf-arphic-ukai
                           Recommends: ttf-arphic-uming
                           Recommends: ttf-kochi-gothic
                           Recommends: ttf-kochi-mincho
                           Recommends: ttf-lao but it is not going to be installed
                           Recommends: ttf-malayalam-fonts but it is not going to be installed
                           Recommends: ttf-thai-tlwg but it is not going to be installed
                           Recommends: ttf-unfonts-core but it is not going to be installed
                           Recommends: wvdial but it is not going to be installed
                           Recommends: plymouth-theme-kubuntu-logo-trinity but it is not installable
E: Unable to correct problems, you have held broken packages.

I don't get step 5 back on the PPA's overview page, look for the Signing key heading. You'll see something like:

1024R/72D340A3 (What is this?)

Copy the portion after the slash but not including the help link; e.g. just 72D340A3

Here is the link if you want to help me: https://quickbuild.pearsoncomputing.net/~trinity/+archive/trinity-nightly-builds/

share|improve this question

3 Answers 3

up vote 0 down vote accepted

There is now a new desktop environment called “Trinity” which is basically the further development of KDE3.

enter image description here

You can install it by following the following instructions.

sudo gedit /etc/apt/sources.list

Add these lines to the end of your sources list, if you are running an older version of ubuntu please see this page before continuing.

deb http://ppa.quickbuild.pearsoncomputing.net/trinity/trinity-v3.5.13/ubuntu/dists/precise/ main 
deb-src http://ppa.quickbuild.pearsoncomputing.net/trinity/trinity-v3.5.13/ubuntu/dists/precise/ main
deb http://ppa.quickbuild.pearsoncomputing.net/trinity/trinity-builddeps-v3.5.13/ubuntu/dists/precise main
deb-src http://ppa.quickbuild.pearsoncomputing.net/trinity/trinity-builddeps-v3.5.13/ubuntu/dists/precise main

Next you want to add the GPG Signing Key.

sudo apt-key adv –keyserver keyserver.quickbuild.pearsoncomputing.net –recv-keys 2B8638D0

Next simply make sure you are up-to-date and install Trinity.

sudo apt-get update
sudo apt-get install kubuntu-default-settings-trinity kubuntu-desktop-trinity

Thats it you should now be able to logout, switch sessions and login to KDE3. Enjoy! =)

share|improve this answer
    
for 12.04 not for 11.10 –  Andrew Sep 28 '12 at 5:33
    
@Andrew-- Check the updated answer –  user61928 Oct 5 '12 at 6:27

It doesn't work look the error:

 sudo apt-get update
 E: Línea 66 mal formada en la lista de fuentes /etc/apt/sources.list (análisis de dist)
 E: No se pudieron leer las listas de fuentes.
share|improve this answer

At the moment there is no packages for ubuntu 12.04. The reason you are getting this error is because the packages you are installing don't exist. You can try using the 11.10 instructions for install ubuntu, but it's not guaranteed to work or not cause issues with installing:

http://www.trinitydesktop.org/wiki/bin/view/Documentation/UbuntuBinaryInstallation

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.