Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently installed a fresh Ubuntu 12.04 LTS on a Samsung R470 Laptop. Before there was Ubuntu 10.?? running with Kernel 3.0.0-?? and everything was working fine. But now after startup when the login screen appears the computer freezes and everything is full of pixel errors and strange graphic artefacts.

In the beginning sometimes the Ubuntu sound appears and it's possible to move the mouse cursor for a few seconds but then all freezes. Not even ctrl+alt+F1 works to switch to a console.

Starting in recovery mode is not very helpful either. Activating the network doesn't succeed as well as repairing broken packages. FailsafeX terminates with the error "no screens found".

However with a detour over recovery mode i can log in normaly as user without gui. Fist i updated with apt-get update and apt-get upgrade all packages and tried as well to install the newest proprietary nvidia drivers (they were already installed). No changes, after booting the log in screen freezes.

Here is the info on the graphics card:

01:00.0 VGA compatible controller: NVIDIA Corporation G98M [GeForce G105M] (rev a2)
Subsystem: Samsung Electronics Co Ltd Device c059
Kernel driver in use: nvidia
Kernel modules: nvidia_current, nouveau, nvidiafb

The file /var/log/Xorg.0.log is empty but i posted the content of /var/log/Xorg.0.log.old here.

Thanks a lot to anyone who can help in solving the problem or in specifying it in a bit more detail.

share|improve this question

closed as off-topic by Eric Carvalho, Mateo, bain, LnxSlck, Mahesh Jul 2 at 17:34

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This describes a problem that can't be reproduced that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – Eric Carvalho, Mateo, bain, LnxSlck, Mahesh
If this question can be reworded to fit the rules in the help center, please edit the question.

    
is there really nobody able to help with the issue? –  MrHee Oct 3 '12 at 2:38
    
The problem is solved now. It was sufficient to install the latest NVIDIA Driver provided on the NVIDIA webpage at: nvidia.com/object/linux-display-ia32-304.51-driver.html The install instructions came from: samael.me.uk/2012/05/how-to-fix-nvidia-graphics-issue-in.html –  MrHee Oct 7 '12 at 4:22

Browse other questions tagged or ask your own question.