Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I picked up an hp dm3t laptop with intel HD graphics and installed ubuntu 10.10 64 bit on it. It works great -- the only problem is that the brightness controls on the keyboard don't work. The brightness is always at full. When I try to adjust it down, the indicator graphic indicates that it's going down but the actual brightness doesn't change. Is there anything that I can try to make this work? I'd really appreciate any help.

I asked this on superuser.com and someone commented that I should play around with the intel hd drivers. I'm a total noob -- how do I do that? What else can I try? I really don't want to go back to windows.

share|improve this question

2 Answers 2

up vote 3 down vote accepted

This seems to be a kernel bug.

You might be interested in reading this bug report, where an Ubuntu kernel developer posted a link to his PPA with a patched kernel (including steps on how to install it).

share|improve this answer
    
This doesn't apply to my graphics driver –  James Dec 30 '10 at 16:04
    
You have an Intel GMA 4500MHD and comments in this bug report suggest that the patched kernel fixes the very same problem with this GPU (eg. #111, #112). –  htorque Dec 30 '10 at 17:54
    
Thanks so much! I'm having trouble finding steps on how to install it. The patched kernel is here: kernel.ubuntu.com/git?p=kamal/… ... I can't seem to find the directions on how to install it. Are they in the README inside of the download? If so, which section do I follow (there seem to be multiple options.) –  James Dec 30 '10 at 20:10
1  
@James: You don't need to compile your own kernel. Just add the PPA to your system. Start a terminal and run sudo apt-add-repository ppa:kamalmostafa/linux-kamal-mjgbacklight, then sudo apt-get update and finally run the upgrade with sudo apt-get upgrade. As you can read in the above link to the PPA, you might need to add acpi_backlight=vendor to the linux-line of the grub entry for the new kernel (see the comments in this answer about how to add parameters to the kernel during boot). –  htorque Dec 30 '10 at 22:08

Try this.

sudo gedit /etc/default/grub

Change the line GRUB_CMDLINE_LINUX="" into GRUB_CMDLINE_LINUX="acpi_osi=Linux"

sudo update-grub

Restart your linux

Credit to this guy: http://livinginjava.blogspot.com/2010/11/ubuntu-1010-brightness-problem-in-acer.html

share|improve this answer
    
This doesn't allow me to change the brightness. Also, the indicator that the brightness is being changed is gone. –  James Dec 30 '10 at 15:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.