Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to install the latest (as of 27/09/2012) nVidia drivers for my GTX 660 through the Additional Drivers tab in System Settings. It ends up aborting, producing a log that says something about XorgDriverHandler not being installed. What do I do to fix it? I've tried to reinstall it by purging it but to no avail.

share|improve this question
    
can i have the output of: nvidia-settings --version –  penreturns Sep 27 '12 at 17:04
    
Kindly see below. –  user93114 Sep 27 '12 at 18:55

1 Answer 1

Check your current version. Open terminal Ctrl + Alt + T and run following command:

nvidia-settings --version

To install nVidia Linux Display Driver under Ubuntu 11.10/12.04, open the terminal and run the following commands:

sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update
sudo apt-get install nvidia-current

My advice, always choose stable release.

Refer this post

Launchpad

My Nvidia Driver Version

enter image description here

share|improve this answer
    
Hi. I get the exact same output as you do when I type in the version command. I get the same error as before, with the jockey log. If I try to install through the GUI, it says that "This driver was just disabled, but is still in use.". What gives? –  user93114 Sep 27 '12 at 18:54
    
What version are you using right now? You can set your nvidia by launch Nvidia X server from dash –  penreturns Sep 27 '12 at 18:58
    
Unsure what you mean, but I can see 1.11.3 Server Vendor Version, 1.28 NV-CONTROL version and the 304.51 NVIDIA Driver version. –  user93114 Sep 27 '12 at 19:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.