Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I was recently trying to change my /home directory to a new hard drive using these instructions.

I got to the step where I have to change the fstab file and I think what I did was I set the location to /home instead of /media/home. Well now when I try to log into my computer, it brings me back to the log in page, but it doesn't say that my password was wrong, so I know that's not the problem.

I've been trying to do the Ctrl+Alt+F2 thing to edit the fstab file from the command line, but its a read-only file. I also tried changing the permissions of the file with chmod, but that doesn't work either.

What else can I do to solve this?

share|improve this question

Try to edit with sudo:

sudo nano /etc/fstab

share|improve this answer
bless you dude, worked like a charm... – ashubuntu Nov 18 '15 at 14:10

Edit it using sudo $EDITOR /etc/fstab

share|improve this answer

Try: sudo vi /etc/fstab and after editing press Esc to get vi go to command mode and then :wq! to save and overwrite

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.