Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to install MATLAB R2010b to Ubuntu 12.04. I have the ISO file. First I copied it to my PC and then extracted it. Now it seems like I should run the install script. But I could not do that.

Here is the beginning of the install script to give you an opinion if it is not a script and I am doing something wrong:

#!/bin/sh
#
# Name:
#    install -  script file for invoking the Multi-platform installer on Linux.
#
#    Usage: install [-h|help]"
#                              [-javadir <directory>] | [-root <directory>] |"
#                              [-test] | [-v|-verbose]"
#                              -h|-help        - Display arguments."
#                              -test           - Don't actually run the java
#                                                command (only useful with -v)."
#                              -v|-verbose     - Display settings."
#                              -javadir <directory>       - Override default java     root directory."
#                              -root <directory>          - Override default DVD root directory."
#
#              The default settings when no override inputs are supplied are: "
#              -root = <directory containing this script>/../"
#              -javadir = <root>/java/jre/$ARCH/jre'
#
#
# Copyright 2009-2010 The MathWorks, Inc.

How can I run this script? I tried to rename it as install.sh and then tried

 $ ./install.sh

from the command window but I got the following error:

root@ghostrider:/home/zero/Downloads/R2010b_UNIX# ./install.sh 
Preparing installation files ...
Installing ...
./install.sh: line 562: /tmp/mathworks_7799/java/jre/glnx86/jre/bin/java: Permission     denied
Finished

Am I doing something wrong? Could you please help me?

Regards

share|improve this question
4  
Do not extract the ISO. It is a CD image, you will need to mount it. Then you can run the installer script. –  queueoverflow Sep 27 '12 at 10:34
    
@queueoverflow you are right! Installation started now. Thank you so much. –  Amadeus Bachmann Sep 27 '12 at 10:49
2  
@queueoverflow - you should move that comment down as an answer –  hbdgaf Sep 27 '12 at 11:56
    
@aking1012: Too late :-) –  queueoverflow Sep 28 '12 at 10:14
add comment

2 Answers 2

up vote 1 down vote accepted

You need to mount an ISO and then install it according to the set up instructions:

share|improve this answer
add comment

You need to give executable permission to sys/java/jre/glnx86/jre/bin/java.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.