Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Following a troubleshooting post I've found out that my driver is recognized in fact but is not listed at the sound settings and I think because of this my cinnamon sound applet will not appear. Altough my device does not appear in the Sound settings I get sounds (for example youtube and skype is working) but I can not increase/decrease the volume...

I tried enabling login with root, login-logout and then login with user, restarts, following other ideas saying to fix this but still no sound devices listed... still it works (browser, skype...), alsamixer works.

Any idea on how to fix this?

lspci -v | grep -A7 -i "audio"
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
Subsystem: Acer Incorporated [ALI] Device 0205
Flags: bus master, fast devsel, latency 0, IRQ 46
Memory at f4700000 (64-bit, non-prefetchable) [size=16K]
Capabilities: [50] Power Management version 2
Capabilities: [60] MSI: Enable+ Count=1/1 Maskable- 64bit+
Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
Capabilities: [100] Virtual Channel
lsmod | grep snd
 snd_hda_codec_hdmi     31731  1 
snd_hda_codec_realtek    63371  1 
snd_hda_intel          32621  0 
snd_hda_codec         115893  3 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_intel
snd_hwdep              13276  1 snd_hda_codec
snd_pcm                80845  3 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec
snd_seq_midi           13132  0 
snd_rawmidi            25424  1 snd_seq_midi
snd_seq_midi_event     14475  1 snd_seq_midi
snd_seq                51567  2 snd_seq_midi,snd_seq_midi_event
snd_timer              28931  2 snd_pcm,snd_seq
snd_seq_device         14172  3 snd_seq_midi,snd_rawmidi,snd_seq
snd                    62064  10 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
soundcore              14635  1 snd
snd_page_alloc         14108  2 snd_hda_intel,snd_pcm

Also... in cinnamon the sound applet is not displayed in unity it displays as if it were muted.

Similar question: Ubuntu 12.04, Can hear the sound but Sound option in settings shows no sound card

share|improve this question
A similar problem was posted here, which I was able to solve on my own laptop. The problem here isn't exactly the same, but thought it worth posting just in case it does respond to the same solution. – DaveInCaz Aug 12 '14 at 1:16

6 Answers 6

Try these commands:

sudo apt-get remove --purge alsa-base  
sudo apt-get remove --purge pulseaudio  
sudo apt-get install alsa-base  
sudo apt-get install pulseaudio  
sudo alsa force-reload
share|improve this answer
done, no errors reported. Still there are no device(s) listed in the Preferences - Sound. Anyway thanks kamil for your assistance. – obeliksz Sep 27 '12 at 11:19
checked, still no sound devices. – obeliksz Sep 27 '12 at 12:05
Skype works with HDA Intel, ALC888 Analog Default Device (default:CARD=Intel) --- stange that in system preferences no devices appear at all. – obeliksz Sep 27 '12 at 12:11
Running only the sudo alsa force-reload fixed the issue for me. – loostro Jun 24 '14 at 15:57
Worked for me. Thanks. – Wildneuro Dec 24 '14 at 0:25

In my case I had a fresh install of Ubuntu 14.04, so reinstalling pulseaudio and alsa would be pointless.

However, running sudo alsa force-reload as in user91632's anwser did the trick.

share|improve this answer

Open the terminal with Ctrl+Alt+T and install pulseaudio with this command:

sudo apt-get install pulseaudio gstreamer0.10-pulseaudio indicator-sound
share|improve this answer
gstreamer0.10-pulseaudio is already the newest version. indicator-sound is already the newest version. pulseaudio is already the newest version. The following packages were automatically installed and are no longer required: gir1.2-folks-0.6 gir1.2-telepathylogger-0.2 gir1.2-telepathyglib-0.12 gir1.2-gee-1.0 – obeliksz Sep 27 '12 at 10:35

Ubuntu Unity 14.04 - 64bit, Intel mobo and i7 processor. After switching sound cards, I had [much better] sound but my sound output choices (System Settings : Sound) disappeared. I needed that to switch to S/PDIF output. After much monkeying around without success, including all of the above suggestions and more, nothing worked. For no particular reason, I logged into a 2nd user account, where I found the new output choices did indeed appear. I'd discovered that the settings were user-account specific. So, while I was there, I looked in .config and found a pulse directory. I copied that directory to the network, then switched back to the primary account. I found my .config/pulse directory (which had several additional files in it) and renamed it to pulse.orig in preparation to copy/paste the 2nd account's pulse directory from the network. But even as I switched directories to copy, then back to my .config directory, a new pulse directory had appeared, with the proper number of files in it. I checked System Settings / Sound, and my new sound devices were available for selection.

Long Story Short: Maybe find your [/home/userid]/.config/pulse directory and rename it (so a new default copy can appear).

share|improve this answer

I had the exactly same problem which occurred after ubuntu upgrade. The following command fixed that for me (adding your system user account into group audio):

sudo adduser my-login-name audio
share|improve this answer
This didin't help me. – loostro Jun 24 '14 at 15:56

In my case I kept the home directory from the previous install so during the install/transfer some of the folders were not owned by me pulse config folder was one of them.

What I had to do was chown -R my_user_name:my_user_name /home/my_user_name/*.

To check if this is your issues just check the owner of /home/your_user_name/.config/pulse.

Once I fixed that the applet started working as expected.
I should say this was on Ubuntu 14.04x64

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.