Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Inside Firefox, I try to check the box in Edit->Preferences->Advanced->General which says Submit crash report, but each time I close the browser and open it again it remains unchecked. What could be wrong?

share|improve this question
    
The box remains checked for me. Which version of Ubuntu are you using? –  8128 Dec 30 '10 at 8:15
    
I think he is using ubuntu 10.04,however the option is checked in ubuntu 10.10.. –  karthick87 Dec 30 '10 at 8:41

3 Answers 3

up vote 1 down vote accepted

It seems that I have discovered the answer. When I asked Firefox to Never remember history, the Submit crash report option will always become unchecked after closing and reopening. However when I changed it to Remember history, the Submit crash report option can finally remain checked.

This is possibly due to the fact that no crash report can be submitted if no history is stored according to the current way the browser is set. In fact, the same thing happens using Firefox in Windows.

share|improve this answer
  • It is because Firefox in Ubuntu repositories is configured to use Ubuntu's crash reporting tools instead of the one built in by Mozilla.
  • Same as with updating Firefox, it's handled through same package management as every other application on your system instead of using Firefox own update tool.
share|improve this answer
    
-1 as your answer is wrong. In Ubuntu, we disabled Apport crash reporting for Firefox and we use the upstream crash reporting tool instead. The upstream crash reporter is enabled on our official builds for 10.04 onwards. –  Chris Coulson Mar 18 '11 at 12:26
    
@chris Karthick, I have added a possible explanation after trial and error. :) –  user7182 May 16 '11 at 21:23

I was having a bit of difficulty working out where firefox stored this setting on ubuntu, because I was limiting my search to the ~/.mozilla/firefox/[profile]/ dir -

For reference sake if anyone else is searching for it and came across this thread like I did, the setting is in: ~/.mozilla/firefox/Crash\ Reports/crashreporter.ini

[Crash Reporter]
SubmitReport=0

or SubmitReport=1 to enable.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.