Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have two laptops,

One is running Ubuntu 12.04 (EXT4) the other is running Windows 7 (NTFS).

I am copying over 40gb of data (one file) from the Ubuntu laptop to the Windows Laptop. (Browse the shared folder on Ubuntu using Windows copy/paste)

But I am getting transfer speeds topping out at ~700kb/s Surely this is not right. I am transferring via wifi on both laptops.

My download speeds can reach 7-8mb/s on both laptops, so I know it is not the wifi cards or the router topping out.

wlan0     Link encap:Ethernet  HWaddr 84:4b:f5:db:b4:85  
          inet addr:192.168.1.66  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::864b:f5ff:fedb:b485/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:11941185 errors:0 dropped:0 overruns:0 frame:0
          TX packets:11306693 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:10087111370 (10.0 GB)  TX bytes:7843524888 (7.8 GB)
share|improve this question
    
Samba file sharing over wifi is really slow indeed, especially if the wireless is 11g. You most likely get 700KBps and not kbps, but that doesn't change the fact that samba over wifi is unsuitable for such huje file transfers. You should use a 1Gbps wired connection for that stuff. –  mikewhatever Sep 27 '12 at 9:09
    
turn caching on on your hdd . Samba is not at fault here. Same problem fixed by enabling caching. –  Piet Mar 1 at 10:45
add comment

4 Answers

I have had similar problems with Ubuntu to Linux - using some of the tips here https://calomel.org/samba_optimize.html I managed to get up to 1.5MBps but it's still painful. This is using both WiFi and a HomePlug connection.

Until I started transferring files sized in gigs, this was (of course) never a problem!

share|improve this answer
add comment

I found this solution from an external thread, I will provide all details here:

1- First Method: A second The first solution for this issue can be by using the following :

Open terminal and enter the following command:

sudo -s gksu gedit /etc/modprobe.d/ath9k.conf

At the end of the file add this:

options ath9k nohwcrypt=1

Save an restart your OS.

If you still have the issue, then try instructions on step 2.

2- Second Method:

This method involves forcing iwlagn to not use n, the commands will disable n on the device without making it a permanant change, check first if this work for you, if you notice that the speed improved then continue to make the change permanant. If this solution didn`t work for you, then reboot your computer to revert the changes.

sudo rmmod -f iwlagn
sudo modprobe iwlagn 11n_disable=1

If you notice that the wifi speed improved, then make the change permanent :

gksudo gedit /etc/modprobe.d/iwlagn-disable11n.conf

and add this line to the file:

options iwlagn 11n_disable=1

save & quit

3- Third method:

You need to disactivate IPv6, to do that, open terminal and enter the following commands:

echo "#disable ipv6" | sudo tee -a /etc/sysctl.conf echo "net.ipv6.conf.all.disable_ipv6 = 1" | sudo tee -a /etc/sysctl.conf echo "net.ipv6.conf.default.disable_ipv6 = 1" | sudo tee -a /etc/sysctl.conf echo "net.ipv6.conf.lo.disable_ipv6 = 1" | sudo tee -a /etc/sysctl.conf

Then restart your system

share|improve this answer
1  
How is any of that related to Samba? How do you know the OP has an Atheros or Intel wireless card? What if it's a Broadcom, Realtek, RaLink or an older Intel? None of them use either ath9k or iwlang, which makes 1 and 2 completely irrelevant. –  mikewhatever Sep 29 '12 at 8:15
add comment

use NFS for file sharing between windows and ubuntu

follow this link to install nfs on ubuntu and this link to install nfs client on windows

share|improve this answer
    
"Windows Services for UNIX" (that are mentioned in your link) don't support Windows 7. –  Roman Mar 5 at 11:09
add comment

Samba can be slow in some scenarios, in my experience. Most likely due to bugs that only show themselves in some cases. I dropped it for NFS (which won't be an option for you) but you can look at things like HTTP, FTP or even bittorrent. They're all a little more painful to set up but in my experience they're all faster than Samba.

Hell, I've had SCP (file transfer over SSH) go faster than Samba.


Pre-post-edit-breakdanceoff:

For a super-simple, probably vastly insecure webserver you open a terminal, cd into the directory you would like to share and run:

python -m SimpleHTTPServer 8000

That seems to bind on all interfaces to port 8000. So just go to http://<your-network-ip>:8000 and you should see a file listing. Amazing!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.