Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

new install of 12.04 on an old dell with a radeon ATI RV516 video card with monitor out and s-video out.

During boot up all is good. Both screens operate and look fine. Then just before the desktop appears, the CRT goes purple and is converted into heavy horizontal lines, but as i said during boot up it was fine and the resolution was fine. The main monitor, an lcd, operates normally.

everything else works fine, it's just the picture on the CRT that is screwed up.

I used the same monitor and CRT running 11.10 which worked fine

any help would be appreciated and yes i am a newbie to ubuntu here is a vid showing the completely normal screens at reboot then the purple badness when the desktop loads ?? and don't laugh at the slow machine, it's old. http://www.youtube.com/my_videos_edit?ns=1&video_id=zfuh6lBMLnc

CRT is a Toshiba 32MW7DB, s-video is a direct input. My xrandr data has no data in the second column for the s-video (apologies for not knowing how to present the data as it appears in the terminal window)

DVI-0 disconnected (normal left inverted right x axis y axis)

S-video connected 1024x768+1680+282 (normal left inverted right x axis y axis) 0mm x 0mm 1024x768 59.9* 800x600 59.9
848x480 59.7
720x480 59.7
640x480 59.4
DVI-1 connected 1680x1050+0+0 (normal left inverted right x axis y axis) 473mm x 296mm 1680x1050 59.9*+ 1280x1024 75.0 60.0
1152x864 75.0
1024x768 75.1 60.0
800x600 75.0 60.3
640x480 75.0 60.0
720x400 70.1

share|improve this question
    
update the video link to youtube.com/watch?v=zfuh6lBMLnc –  gion_13 Sep 27 '12 at 9:38

1 Answer 1

Check your display settings. You may need to tell Xorg (It manages displays) what refresh rate your CRT needs.

Try different options for your second monitor, notably the refresh rate. CRTs, if I recall correctly, don't like the same rate as LCDs.

share|improve this answer
    
when i go to system settings-diplays all i can do is change the resolution and that only makes what is a purple mess become a green mess. How do i change refresh rates please? What i find confusing is the CRT screen is perfectly fine during boot up. thank you –  rhys Sep 27 '12 at 21:59
    
Take a quick look at this, it might be helpful: askubuntu.com/questions/147580/… Also, please edit your question with info on your crt monitor brand and model as well as output from 'xrandr'. CTRL+ALT+T, then xrandr –  Steve Sep 29 '12 at 2:20
    
thanks, have added data above –  rhys Sep 29 '12 at 4:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.