Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I host a hub using Ynhub on Windows with port I want to continue the hub on Ubuntu.

I couldn't find Ynhub software for Linux, so I tried opening it with Wine. But hosting ports more than 1023 only works.

It shows up this error if I tried to host with port 511:

Failed to start listening on port 511, port may be inuse 

and same errors respectively for all ports less than 1024.

Can I do anything to host my hub (using Ynhub) with 511 port? Otherwise I will have to lose all my users. Please help.

share|improve this question
up vote 0 down vote accepted

There are problems with Wine and YnHub for a while now.

Since you have linux, why don't you use Verlihub or PtokaX instead? They are more robust and of course, YnHub has many connection problems even on Windows (not mentioning MANY security issues).

EDIT: Or other solution, you must create Virtual Machine with Windows installed and then use YnHub on Windows within virtual OS.

Edit: You may also use port forwarding from a your router to help you. Just create YnHub port to one that is higher than 1023 and then use port forwarding from outside port 511 to your internal YnHub port.

share|improve this answer
Thanks for the reply. I am having problem installing Verlihub :( I don't have experience with terminal much.I was following the instructions given . I get this error : "checking for C++ compiler default output file name... configure: error: C++ compiler cannot create executables" when I type configure in verlihub folder – dhootha Sep 27 '12 at 6:21
You need to install C/C++ compiler. to do so you may use this terminal command: sudo apt-get install build-essential. :) Then try installation again. – HelpNeeder Sep 27 '12 at 6:24
Also, there are few tutorials on google that tells you how to install Verlihub. This is example tutorial. – HelpNeeder Sep 27 '12 at 6:26
Thanks again!!!!! Quick replies made me very happy :) – dhootha Sep 27 '12 at 6:37
PS, I just found out that Ubuntu won't let you use ports under 1024 unless it runs in root privileges... Therefore upper port should have worked. – HelpNeeder Apr 17 '15 at 22:31

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.