Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Suddenly I cannot access any https connection. Firefox shows an error

Error code: ssl_error_rx_record_too_long

Even I cannot access Google (http). It shows blank page most of the time. I did not do anything at all. I Googled about ssl error but all indicated apache2 virtual-host fact. But I don't have apache installed in my system. I did not change any kind of config file. So why is it happening?

I am using a modem (with WiFi router facilities). Other computers in this network are working just fine. I am using 12.04 64bit. System date is okay (synchronize with time server).

share|improve this question
add comment

1 Answer

Make sure that port 443 is open and enabled on your server. This is the standard port for https communications.

If this doesn't solve your problem its better to connect to Firefox support

I've seen there problems like this but only for specific website and the solution was to remove some Addons so its better to tell them your peoblem in details if my answer doesn't help you

share|improve this answer
    
It is not firefox's problem.Same problem for chrome and chromium-browser. I am not running any server and do not use any proxy. How do i check open port? –  shantanu Sep 27 '12 at 7:25
    
iptables -A INPUT -i eth0 -p tcp --sport 443 -m state --state ESTABLISHED -j ACCEPT This command will open this port –  user61928 Sep 27 '12 at 7:35
    
It's the port for the secure connection –  user61928 Sep 27 '12 at 7:57
    
@IZX --- By default, HTTP uses port 80 and HTTPS uses port 443 –  user61928 Sep 27 '12 at 8:01
1  
Yes, 443 is the port ON THE SERVER; the OP here has a problem WITH THE CLIENT. –  izx Sep 27 '12 at 8:23
show 6 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.