Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This is my cron task for rsync

00 03 * * * /usr/bin/rsync --delete -aAXv /* /media/mirror --exclude={/dev/*,/proc/*,/sys/*,/tmp/*,/run/*,/mnt/*,/media/*,/lost+found,/home/*/.gvfs} && /bin/date | /bin/cat > /home/william/ubuntu-server-backup/last_rsync.txt

This is in root's crontab. The destination drive ( mirror) has the same capacity as the main disk.

I verified, and the symbolic links are still links, they have not been copied twice.

What am I doing wrong?

EDIT: I just checked, and it looks like ''/media'' is not excluded. why? I got my command from the Arch Wiki.

share|improve this question
    
That is a very weird exclude syntax. I'd recommend using an exclude list text file with --exclude-from, or multiple --excludes for each directory. Also try adding the --delete-exclude option. –  izx Sep 27 '12 at 8:26
add comment

1 Answer

It seems to be a bug according to https://bugzilla.samba.org/

see this

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.