Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've a lenovo thinkpad edge e430. I use headphones provided by lenovo. Today afternoon I did an update and now my headphones aren't working in Ubuntu. Sucks not being ablet o hear music while programming.

Is anyone facing similar problem? Any known fix?

share|improve this question

1 Answer 1

https://help.ubuntu.com/community/SoundTroubleshootingProcedure

You can aslo execute this command and reboot:

sudo add-apt-repository ppa:ubuntu-audio-dev/ppa; sudo apt-get update;sudo apt-get dist-upgrade; sudo apt-get install linux-sound-base alsa-base alsa-utils gdm ubuntu-desktop  linux-image-`uname -r` libasound2; sudo apt-get -y --reinstall install linux-sound-base alsa-base alsa-utils gdm ubuntu-desktop  linux-image-`uname -r` libasound2; killall pulseaudio; rm -r ~/.pulse*; sudo usermod -aG `cat /etc/group | grep -e '^pulse:' -e '^audio:' -e '^pulse-access:' -e '^pulse-rt:' -e '^video:' | awk -F: '{print $1}' | tr '\n' ',' | sed 's:,$::g'` `whoami`

The command will work even it will produce many errors

Another Solution you can try the following:

  1. Open the terminal and edit the alsa-base.conf file with this command:

    sudo gedit /etc/modprobe.d/alsa-base.conf

  2. At the end of the file, add this line:

    options snd-hda-intel model=eapd probe_mask=1 position_fix=1

  3. Press Ctrl+Q and save your file, then reboot your system so that new changes take effect.

Audio will now be restored to your Headphones.

Good luck!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.