Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried running Ubuntu 12.04 desktop from a usb, got an error back. Using ubuntu by running it virtually to recover my files, windows is kinda corrupted.

My computer specs:

Computer: hp pavillion dv 9000
OS: Windows vista 32 bit
CPU: AMD Athon X2
Graphics: NVIDIA Geforce Go 7150
Wireless: Broadcom

all the process shows ok onthe right until the squasfs errors like

28.267297: SQUASHFS error: zilb_inflate error, data probably corrupt
   "  324:               : squashfs_read_data failed to read block 0x275fcda4
   "  340:               : Unable to read fragment cache entry [275fcda]
   "  351:               :         "      page, bock 275fcda4, size 6eb7

So do I need to give anymore information, and please tell me there is a solution.

My finals are coming up and my assignments are stuck in the hardisk, crap imma fail.

share|improve this question
add comment

1 Answer 1

To restore the Windows Vista bootloader, you must first boot off your Windows Vista installation DVD.

If you have one of the many OEM computers that didn't come with a Vista installation disk, you can get the same effect with a Vista recovery disk, which you can download or create from another Vista/7 computer (see this page and this tutorial).

When you get to the Regional settings, select your Location/Keyboard setting then click next.

On the next page you must click on "Repair your computer."

On the next page, if it finds your Windows Vista installation, make sure it is UNSELECTED before clicking next.

Then click on "Command prompt". From there, type in the folowing:

bootrec.exe /fixboot

bootrec.exe /fixmbr

Now close the two windows and click "Restart."

Take out your Vista DVD and hopefully, you will be left with your Windows Vista Bootloader.

If you dont want also to restore Ubuntu

Boot into the Ubuntu 12.04 Live CD and click "Try Ubuntu without installing":

enter image description here

After the desktop is loaded, we need to mount the root partition so that we grant the live cd user read/write permissions on your system files and folders. Let's first identify the partition where Ubuntu is installed with this command:

sudo fdisk -l

Note: The Terminal can be started by pressing CTRL+ALT+T.

The Ubuntu partition we will work on will be labeled with the word "Linux" as shown in the screenshot given below:

enter image description here Run now this sequence of commands to mount the root partition:

sudo mkdir -p /media/ubuntu

sudo mount /dev/sda1 /media/ubuntu

Then you need to mount these system folders to use them on your current desktop environment:

sudo mount --bind /dev /media/ubuntu/dev

sudo mount --bind /proc /media/ubuntu/proc

sudo mount --bind /sys /media/ubuntu/sys

Now chroot into your hard drive with this command:

sudo chroot /media/ubuntu

You have now read/write permissions on your root partition. To install GRUB2, you need to use one of these two commands:

grub-install /dev/sda

or

grub-install --root-directory=/media/ubuntu /dev/sda

Note: the "sudo" is not required since you are logged in as root now. Also keep /dev/sda as is.

If the installation is successful, you will get these outputs:

root@ubuntu:/# grub-install /dev/sda

Installation finished. No error reported.

Update GRUB2 with this command:

update-grub

Now Remove the Ubuntu installation CD and reboot your system to see if the GRUB2 boot menu is restored or not.

share|improve this answer
    
You are not going to install VISTA by this way. By this way you've gonna restor your bootloader and thus you can boot Windows Vista to get your data back and sure you are not in need for recovery now. your problem will be solved easily –  user61928 Sep 27 '12 at 7:49
    
ok I did not see the edit and pictures on your first post. For Ubuntu I selected "Trying without installing". When loading to the desktop, It checks for the battery state and other stuffs was ok until the errors '28.267297: SQUASHFS error: zilb_inflate error, data probably corrupt' '324: : squashfs_read_data failed to read block 0x275fcda4' " '340: : Unable to read fragment cache entry [275fcda]' " '351: : " page, bock 275fcda4, size 6eb@#' –  YBZ Sep 27 '12 at 8:08
    
read this topic about the possible errors and causes help.ubuntu.com/community/SquashfsErrors –  user61928 Sep 27 '12 at 8:10
    
please vote up and accept as answer if this solve your problem –  user61928 Sep 27 '12 at 8:21
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.