Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So, the short version of my sad story is that I tried upgrade Ubuntu to 12.04 and wireless driver has stopped working. I have tried all the solutions but nothing seem to be working.

When I try to install my wireless from "Additional Drivers" Its says:

Sorry, installation of this driver failed. Please have a look at the log file for details: /var/log/jockey.log

The lspci command gives me the following info about wireless:

0c:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g LP-PHY (rev 01)

I have tried removing bcm drivers and reinstalling, but nothing seems to be working. rfkill is good too.

share|improve this question
    
Hmmm ... I have a Dell laptop, too (Studio 1535) and I get the exact same information as you when I run lspci. And mine works! It's running the "Broadcom STA wireless driver." –  Kelley Sep 26 '12 at 21:11

1 Answer 1

There are several reasons for that, possible cause:

Your OS is not with all modules inserted.

Solution:

  1. Type: lsmod > list1.txt

  2. Then create a USB installer with the "Startup Disk Creator" using the ISO of your installation CD (a pen of 2GB is enough).

  3. Then boot from that USB PEN and choose "Try Ubuntu" and type there: lsmod > list2.txt and copy this file to the same location the one above and open both in text editor and see if there is missing modules in list1.txt.

  4. To install missing modules use first modinfo <name of the module> after the description see if it needs dependencies and install those first if not, just copy the full path of the kofile and type sudo insmod <path/file.ko>, after all modules inserted no need for reboot things should start working fine.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.