Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using Dell inspiron 5420 (14R 3rd generation), and tried to install Ubuntu 10.10, 11.10, 12.04, 12.04.1 but each and every time, it doesn't support any of my driver such as network card, wireless driver, video driver and as well as audio and touch-pad driver. audio, video and touch-pad works with their basic functionality but don't work with their full functionality.

I'm a new user of Ubuntu, and willing to use it permanently. In this condition I tried some solutions from the web but didn't get out from this problem.

For this I'm knocking to you, if you give me the proper solution for getting out of this problem, I'll be very grateful to you all.

share|improve this question
1  
Firstly, welcome to Askubuntu :) Next, did you try installing the additional hardware drivers required? If not, try How do I install extra drivers?. Lastly, instead of asking people to mail you the solution, please do check your notifications on any StackExchange sites, or change the settings so that an e-mail is sent to you once every three hours if there's a new notification for you. –  nitstorm Sep 26 '12 at 19:06
    
We can't mail the directions to you, you did not leave your mailing address... all I see is an email address... –  TheX Sep 26 '12 at 19:09

1 Answer 1

This is my compilation for networking in Dell Inspiron 5420 using 12.04. To find the link please visit my blog.

To activate wire network:

  1. Install compat wireless with this version compat-wireless-2012-02-28-p

    ./scripts/driver-select alx
    make
    sudo make install
    
  2. Reboot and plug in your wire network.

  3. After you wired network is up now its time fire up the wireless. Download this file.

    sudo dpkg -i wlan_amd64.deb
    

    First time it will fail then you have to do

    sudo apt-get -f install
    

    then it will get all file need to install wlan_amd64.deb

  4. Reboot your laptop.

All done.

share|improve this answer
    
Please consider using official pre-built compat-wireless packages instead of compiling from source and install packages from unofficial sources. See my answer in another question. –  gertvdijk Dec 28 '12 at 11:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.