Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Today I was notifed of updates, some of them being libapt.

So I press "Install Updates", and I got this error:

The following packages have unmet dependencies:

libapt-inst1.4:i386: Depends: libapt-pkg4.12 (>= 0.8.16~exp12ubuntu10.2) but 0.8.16~exp12ubuntu10.3 is installed
                     Depends: libc6 (>= 2.4) but 2.15-0ubuntu10 is installed
                     Depends: libgcc1 (>= 1:4.1.1) but 1:4.6.3-1ubuntu5 is installed
                     Depends: libstdc++6 (>= 4.4.0) but 4.6.3-1ubuntu5 is installed

So I open the terminal and typed sudo apt-get install -f I was shown this:

The following extra packages will be installed:
  libapt-inst1.4 libapt-inst1.4:i386 libapt-pkg4.12:i386
The following NEW packages will be installed:
The following packages will be upgraded:
  libapt-inst1.4 libapt-inst1.4:i386
2 upgraded, 1 newly installed, 0 to remove and 18 not upgraded.
1 not fully installed or removed.
Need to get 0 B/1,146 kB of archives.
After this operation, 3,031 kB of additional disk space will be used.
Do you want to continue [Y/n]?

I selected "yes".

And then:

E: Internal Error, No file name for libapt-pkg4.12

Also, when I open the software center, I get a message that the database is broken...

I'm using 12.04 64bit

But why it wants to install the i386 version? I'm using 64 bit ubuntu...

share|improve this question
Did you try sudo apt-get install ia32-libs first? –  blade19899 Sep 26 '12 at 14:28
No, I didn't. I fixed the problem by downloading the deb files and istalling them manually. –  Minas Mina Oct 3 '12 at 22:31
what is the output of apt-cache policy libapt-pkg4.12 –  user224082 Nov 19 '13 at 12:39

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.