Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have an Asus EEE PC 1225B with fresh Lubuntu 12.04. And no sound. It doesn't seem to be some common problem, so I have to make some research what's up. I tried running alsamixer, so I know I have Realtek ALC269VB with nothing muted unexpectedly. What can I do next to identify and solve the problem?

Additional info:

alsamixer shows two cards: HD-Audio Generic and HDA ATI-SB (Realtek ALC269VB); the first one is muted.

~$ aplay
ALSA lib pcm_dmix.c:1018:(snd_pcm_dmix_open) unable to open slave
aplay: main:682: błąd otwierania audio: Nie ma takiego pliku ani katalogu

The Polish part can be translated as "error opening audio: There is no such file or directory".

~$ sudo lspci -v | grep -A7 -i "audio"
00:01.1 Audio device: Advanced Micro Devices [AMD] nee ATI Wrestler HDMI Audio [Radeon HD 6250/6310]
    Subsystem: ASUSTeK Computer Inc. Device 103b
    Flags: bus master, fast devsel, latency 0, IRQ 44
    Memory at feb44000 (32-bit, non-prefetchable) [size=16K]
    Capabilities: [50] Power Management version 3
    Capabilities: [58] Express Root Complex Integrated Endpoint, MSI 00
    Capabilities: [a0] MSI: Enable+ Count=1/1 Maskable- 64bit+
    Capabilities: [100] Vendor Specific Information: ID=0001 Rev=1 Len=010 <?>
00:14.2 Audio device: Advanced Micro Devices [AMD] nee ATI SBx00 Azalia (Intel HDA) (rev 40)
    Subsystem: ASUSTeK Computer Inc. Device 103b
    Flags: bus master, slow devsel, latency 32, IRQ 16
    Memory at feb40000 (64-bit, non-prefetchable) [size=16K]
    Capabilities: [50] Power Management version 2
    Kernel driver in use: snd_hda_intel
    Kernel modules: snd-hda-intel
share|improve this question
It seems installing pulseaudio helps. (I wish I knew why exactly.) – Kalmar Oct 6 '12 at 12:06

Do you see more than one output in Sound Settings? My Eee had both digital and analog audio out and only one of them worked.

share|improve this answer
Interesting, I see no Sound Settings in Preferences... That's the place where I should look for them, right? – Kalmar Sep 26 '12 at 13:21
Sorry, I missed the L in front of your Ubuntu. :$ Not sure how to get to the settings there. – otus Sep 26 '12 at 17:10

First, aplay requires an argument. In this case it would be aplay -l to list the devices.

Secondly, with the Asus eeepc there frequently is a problem that ALSA often sees two sound cards: HD-Audio Generic (essentially a virtual device,that doesn't actually play music but mighty worh with an HDMI cable to another device) and the required HDA ATI SB. The simplest way to check it is to launch aplay -l.

If HD-Audio Generic is the first card (0) it is the default card. If it is the case, than you're likely to have no sound unless the default card is switched from 0 to 1.

If it doesn't exist create /etc/asound.conf ...add the following three lines.

defaults.ctl.card 1
defaults.pcm.card 1
defaults.timer.card 1

...give that a whirl.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.