Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am not very experienced in linux and have this problem with microphone which works fine on Windows. Microphone is external one and when listening to recorded sound (both Sound Recorder and Skype Echo Test) you can hear crackling noise.

I fixed output crackling by replacing

load-module module-hal-detect 

with

load-module module-hal-detect tsched=0 

in /etc/pulse/default.pa but I have no idea how to fix input.

Hardware info:

Card: HDA ATI SB                                    
Chip: Realtek ALC272X 

Thanks for help!

share|improve this question
    
Exactly same problem here :P –  Paulocoghi May 20 '13 at 14:46
    
Can you plug it into the line in socket instead of microphone and change you input in sound settings? –  BiggJJ Jul 5 '13 at 20:22
    
linking to relevant thread ubuntuforums.org/showthread.php?t=2163489 –  Elijah Lynn Nov 1 '13 at 21:26
add comment

3 Answers 3

Try and see if the same mic has the same problems on a different computer.

If the sound is still there then get a new mic.

If not then try and see if there is some dirt or other junk in the port.

If there is no junk in the port and there is still a problem then see if there is a loose connection on the inside of the computer. If you use the mic port a lot then it is most likely crack from the motherboard (it is easy to do this unfortunately).

share|improve this answer
add comment

I don't really have an answer yet, but I have a similar problem with a crackling / glitchy microphone input, and I have a small test to show that this is due to pulseaudio.

First of, some info about my card:

$ arecord -l
**** List of CAPTURE Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC888 Analog [ALC888 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 2: ALC888 Analog [ALC888 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
$ lspci | grep -i audio
00:1b.0 Audio device: Intel Corporation NM10/ICH7 Family High Definition Audio Controller (rev 01)

Also, this is how I had alsamixer set up for capture (remove the last "m" from the image URLs to get full resolution):

alsamixer

Now, if I fire up Audacity, this is what I get for input devices:

audacity-inputs

When I use pulse: Mic:0, and record, and zoom in the capture, this is what I get:

audacity-pulse

It is obvious there are small "pulses"/"clicks" that cause the crackling sound.

However, if I use the HDA Intel: ALC888 Analog (hw:0,0): Mic:0, and record, and zoom in the capture, this is what I get:

audacity-ALSA

... that is - no "pulses", and thus, no crackling sound.

The "HDA Intel:..." input(s) should be directly from ALSA, bypassing pulseaudio - which would confirm that pulseaudio is the problem. Note that sometimes while selecting the "HDA Intel:..." input and recording from it, I get only silence recorded, in which case I can stop pulseaudio with:

$ pulseaudio --kill

... and afterwards can obtain a proper capture of "HDA Intel:..." input; and mostly after a

$ pulseaudio --start

... afterwards, I do not have a problem recording from the "HDA Intel:..." input, even with pulseaudio running.

Now, the interesting thing is that the "pulses" may be 3 or 4 samples wide - but they are always 441 samples apart! Which is interesting, because that is exactly the rate (here 44100) divided by 10! Which points to me that this is some sort of a resampling issue in pulseaudio. I've found the page AJvG --- Linux Skype audio problem solved talking a bit about changing some pulseaudio related files for the sample rate, but I haven't yet tried it...

share|improve this answer
add comment

I had the same issue. Try installing alsa-mixer and by using it try to mute one channel of the input (either left or right).

share|improve this answer
    
Didn't work. Tried to mute both left and right channels in Capture section (not at the same time of course) but after recording voice with Sound Recorder only one channel was playing and still crackling. –  Tomas Sep 26 '12 at 13:34
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.