Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed ubuntu 12.04.1 alternative install (for raid 0 on some disks). I Have some problems with the net. I'm at school, we use cable, and it got IPv6.

If I run ifconfig eth0 heres my output:

eth0      Link encap:Ethernet  HWaddr e0:cb:4e:87:ff:db  
          inet addr:128.39.194.217  Bcast:128.39.194.223  Mask:255.255.255.224
          inet6 addr: 2001:700:1100:8008:e2cb:4eff:fe87:ffdb/64 Scope:Global
          inet6 addr: fe80::e2cb:4eff:fe87:ffdb/64 Scope:Link
          inet6 addr: 2001:700:1100:8008:48f7:c23:1d87:da6c/64 Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1063378 errors:0 dropped:0 overruns:0 frame:0
          TX packets:489811 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:1577173461 (1.5 GB)  TX bytes:37043669 (37.0 MB)
          Interrupt:68 Base address:0x6000

My /etc/network/interfaces look like this:

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface

auto lo
iface lo inet loopback
# The primary network interface
auto eth0
# NetworkManager#iface eth0 inet dhcp
# NetworkManager#hostname 2001:700:1100:1::4
# This is an autoconfigured IPv6 interface
iface eth0 inet6 auto

(I had to remove the hash tags, because of the BIGFONT i get on ask ubuntu)

The "network manager" says that I'm not connected.

Let me know if you need any more information. :)

share|improve this question
    
comment all lines except auto lo and iface lo inet loopback –  user91632 Sep 26 '12 at 7:22
    
what "Sudo dhclient eth0" does?? –  user291840 Jun 9 at 7:16

3 Answers 3

up vote 0 down vote accepted

Ok so I have a way better answer then I had before.

How about we try this.

Open a terminal.

gksu gedit /etc/rc.local

Add: sudo dhclient eth0 like so.

#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.
sudo dhclient eth0
exit 0

Save & Close. Reboot and should work.

share|improve this answer
    
Just make sure you place it before exit 0 and you should be good to go. –  mywebslave Sep 26 '12 at 8:32
    
Glad to see that it worked for you. –  mywebslave Sep 26 '12 at 9:04

You can create a launcher for your command then put it in the autostartup applications

To create a launcher:

Using ALT+F2 type

gnome-desktop-item-edit --create-new ~/Desktop

This will launch the GUI Dialog and create a launcher on your Desktop:

enter image description here

Prerequisites

gnome-desktop-item-edit is installed automatically if you have installed gnome-shell/gnome-fallback. It is also installed automatically if you have previously installed gnome-tweak-tool.

Alternatively, you can install the old gnome-panel without much of the bulk:

sudo apt-get install --no-install-recommends gnome-panel
share|improve this answer

Your NetworkManager has for some reason commented out the necessary configuration to make DHCP pick up an IPv4 address. Maybe it was a bug or you configured it to turn off IPv4? This is why it isn't working.

# NetworkManager#iface eth0 inet dhcp

To resolve the problem, simply restore the configuration.

iface eth0 inet dhcp

Also check your NetworkManager configuration and make sure you didn't disable IPv4 on the interface.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.