Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Hi I have a Intel Core i5 with 6GB of Ram using ubuntu 12.04 64bit.

I noticed that whenever I run chrome which is the faster browser for me in linux) when I watch youtube, the CPU usage for Chrome is at least 13% and sometimes even 30% .

but in Windows 7 same thing (youtube on chrome) rarely uses more than 6% of my CPU usage. I also notice my laptop is so hot in ubuntu 12.04 and the fan is working all the time, while in windows the laptop is so silent and the fan doesnt make much noise all the time and not as warm as in linux.

is it like that for every one or is it just me?

share|improve this question
    
I have the same problem, try installing drivers for your graphic card. It worked for me, the heating stopped but my laptop hangs with the graphic card drivers so i uninstalled them and my laptop gets very hot now. –  hemanth meka Apr 15 at 21:49
add comment

3 Answers 3

Yes, flash is bad.

You can switch to HTML 5 Videos in Youtube: Go to the bottom -> "Try something new" and choose to be in the HTML 5 Beta.

Videos will work much faster because of better hardware acceleration and no flash

share|improve this answer
1  
I changed my youtube to HTML 5 but surprsingly it uses more CPU !!! normally it uses like 35-40% but after enabling the html5 it uses 44% of the cpu !!! but atleast there is something good , when I switch to HTML I can change the speed of the video –  Medya Sep 26 '12 at 12:34
    
but thanks for the tip anyway –  Medya Sep 26 '12 at 12:36
add comment

Flash in Windows probably uses hardware acceleration so the movie decoding is really being done by the GPU and not your processor. Under Linux, it's all processor unless you are fortunate enough to run a working Flash that lets your system use the GPU.

Try Google Chrome as it uses the pepper flash project and currently sits on Flash 11.3 which works well on my system for hardware accelerated videos on YouTube.

share|improve this answer
add comment
  1. Navigate to the Find Flash Player Version page.

  2. Verify that you are in the section titled "Find Flash Player version type and capabilities (Flash developers only)"

  3. Right click on your Player version and select "Settings"

  4. The Settings dialog will appear, change the tab at the bottom to display (if not already there) and uncheck (or if you'd like to enable, check) the "Enable hardware acceleration" checkbox.

  5. Close the dialog and restart your browser.

share|improve this answer
    
I did that, are you suggesting using Hardware Accelration or not? I tried with both, not much difference in cpu usage, both of them are around %40 –  Medya Sep 26 '12 at 12:34
    
I tried firefox, it uses 6% but it has another thing called plugin container (which is part of firefox) that uses 33% so it is the same, and in Firefox I tried HTML5, even in Firefox HTML5 uses more cpu than flash !!!! very surprsing !!! –  Medya Sep 26 '12 at 12:54
1  
Haedware acceleration is disabled by on Linux by default, regardless of what that setting shows. Check out this question for some more info. –  mikewhatever Sep 30 '12 at 2:15
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.