Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am running Ubuntu 11.10. I used the directions here to replace Unity with Gnome. It seemed to work fine until the end of step 2 when I rebooted the computer. When I chose the default option, I just got a black screen. When I choose the restore option and then "Restore normal boot" I get

Starting load fallback graphics devices    [fail]
Starting GNOME Display Manager [ok]
Starting Userspace bootsplash [ok]
Stopping GNOME Display Manager [ok]
Stopping Userspace bootsplash [ok]
Starting web server apach22    [fail]

(among a lot of OKs)

It finally gets to Stopping System V runlevel compatibility [ok] where it hangs. I left it overnight and just had a blank screen when I checked it in the morning.

I can "Drop to root shell prompt" and "Drop to root shell prompt with networking". I did see here that one should be able to fix the problem by choosing remount and then doing

apt-get install lightdm

I tried this as root shell with and without networking and got the message

Err http://us.archive.ubuntu.com/ubuntu/ oneric-updates/main lightdm i386 1.0.6-0ubuntu1.7
Could not resolve 'us.archive.ubuntu.com/ubuntu'

What is the best way to resolve this problem?

Thanks, Peter.

share|improve this question
    
The page you refer to doesn't exist. But you do need networking in order to download things from the web, so try opening a root shell with networking. –  Jo-Erlend Schinstad Sep 26 '12 at 0:15
    
I opened the root shell with networking but I got the same result. Is there a way to stop it looking for that page or at least looking for a page that exists? Thanks, Peter –  OtagoHarbour Sep 26 '12 at 0:25
add comment

1 Answer 1

I did some digging around on this site and found that I needed to type

dhclient eth0

to get Internet connectivity since I had wired Internet connection. From there it was plain sailing. Thank you Jcubed!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.