Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I somehow had them working before in 11.10 but I don't really remember what did I do back then other than activating "load Gnome components on start up" in the XFCE's settings manager.

I've tried the same in 12.04 but doesn't seem to do anything, I specifically ask for the Volume notifications as other notifications used notify-osd or xfce4-notifyd but the volume one was Gnome's (I found that later) As far as I know it uses notification-daemonbut installing it instead of the other two doesn't give me the correct notifications.

I'm using XFCE 4.10

This is what I get from running gnome-settings-daemon in the Terminal.

(gnome-settings-daemon:3841): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1137:14: Not using units is deprecated. Assuming 'px'.

** (gnome-settings-daemon:3841): WARNING **: You can only run one xsettings manager at a time; exiting

** (gnome-settings-daemon:3841): WARNING **: Unable to start xsettings manager: Could not initialize xsettings manager.

** (process:3849): WARNING **: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files

** (gnome-settings-daemon:3841): WARNING **: Unable to register client: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files

** (gnome-settings-daemon:3841): WARNING **: Name taken or bus went away - shutting down
share|improve this question

2 Answers 2

up vote 1 down vote accepted
+200

The short answer is: No, You cannot use it in XFCE.

You correctly said, Gnome-Shell's volume notification is it's own and it uses notification-daemon. The notification-daemon is a program used to display the pop-up notification. You can use "notification-daemon" is a generic name for any daemon providing notification. For XFCE it is xfce4-notifyd.

Gnome-Shell uses gnome-shell-hotplug-sniffer program which resides in /usr/lib/gnome-shell/ to give the Volume notification. As this is a very internal component of gnome-shell (it runs automatically with gnome-shell) you cannot use it without installing gnome-shell or using it.

To see that this indeed is responsible for Volume notification, temporarily disable it by renaming it to gnome-shell-hotplug-sniffer.bak file

sudo mv /usr/lib/gnome-shell/gnome-shell-hotplug-sniffer /usr/lib/gnome-shell/gnome-shell-hotplug-sniffer.back

Then restart gnome-shell with the command gnome-shell --replace from Alt+F2 graphical command box. Try mounting a drive and you'll see there is no notification for mounted drive.

To restore back the file, use this command to rename it to original name

sudo mv /usr/lib/gnome-shell/gnome-shell-hotplug-sniffer.bak /usr/lib/gnome-shell/gnome-shell-hotplug-sniffer
share|improve this answer

Run gnome-settings-daemon in the background. It handles special keys, keyboard layouts, and the like.

EDIT:

Should've tested that before posting.

You can get gnome-settings-daemon running with:

$ killall xfsettingsd && gnome-settings-daemon

Note that this will set your GTK theme to the default old-school GNOME2 look. But you will have your GNOME-style volume pop-ups.

share|improve this answer
    
I get errors, it shuts down when running, I'll edit the question. –  Uri Herrera Oct 2 '12 at 1:09
    
Nope, still get the regular notifications but It does default to the Raleigh theme. –  Uri Herrera Oct 3 '12 at 1:47
    
Bummer. I actually get the little GNOME keyboard / volume popups on my setup. –  Eric Oct 4 '12 at 11:20
1  
gnome-settings-daemon runs in Unity also, but we do not get that popup in Unity. So, it definitely isn't gnome-settings-daemon –  Anwar Shah Oct 7 '12 at 17:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.