Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using 12.04 on an Acer 722, and just after I've installed MESA drivers to use open source graphics drivers, the wireless connection stopped working. As soon as I've removed bcm STA drivers, the adapter came back to life, finds my router, connects, fetches an IP address from the DHCP server (mikrotik) but no browsing.

On terminal, I've ping'd my router ( and after a good amount of time, it starts answering "unreachable". Through cable everything seems fine. Other devices run fine under this same network (as this same netbook did before with the STA drivers).

Is there a way I can run the previous driver (it fails with blacklist error on jockey log, even after I've put an # mark before the blacklist marking on the blacklist file) or are there any other options?

Update: Yes, everything comes out fine from the DHCP server. When I try to PING the provided address from another station, it goes "unreachable". (that also happens after a good amount of time on the netbook, updated above) Setting all the IPv4 info manually, the same occurs. The addresses are on the accordingly range.

I've posted the question as "last resort" since I've tried everything that I could found on web so far, even issues that weren't like mine but involved similar hardware. With ATI'ś proprietary graphics driver from AMD website I did not have such issues, since the STA driver worked flawlessly. But once MESA drivers were installed, I can't enable it anymore. I'd rather stick with the open source drivers, because the overall machine seems to run faster and there are no hibernation issues.

share|improve this question
Posting the actual errors (after googling them yourself) helps people better understand your problem. – ijk Sep 25 '12 at 21:03
What didn't work when you looked at similar problems... – ijk Sep 25 '12 at 21:06

Made it work. If you're an AspireOne 722 owner, the best thing to do is:

First: follow the steps on the link below, be sure to install the open source video drivers, since it also installs drivers for several devices on your netbook:


Second: run those on terminal:

sudo apt-get purge bcmwl-kernel-source broadcom-sta-common broadcom-sta-source
sudo apt-get install b43-fwcutter firmware-b43-installer

If it does not work still, reset your router to factory settings. Running the code brought my broadcomm back to live. Before the factory reset, the router worked fine with wired and wireless connections BUT both the netbook and an iPad, connected fine but refused to browse.

share|improve this answer

Does the DHCP set as the gateway?

Is the IP address that it gives you in the same range for example 192.168.88.something?

Can you ping the IP assigned by the DHCP?

Have you tried adding your network settings manually?

share|improve this answer
The poster says that pinging an IP address doesn't work. Until that works DNS is not going to help :-/. – ijk Sep 25 '12 at 20:59
I have changed my answer accordingly – CoalaWeb Sep 26 '12 at 6:51

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.