Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
How do I resolve unmet dependencies?

After trying to run a .M4A and a .MP4 (aren't they same thing?) I get a message saying I need to install extra codecs. When attempting to do this, I get an error window stating 'dependencies not met' for the codecs. The error report is this: The following packages have unmet dependencies:

gstreamer0.10-ffmpeg: Depends: libavcodec-extra-53 (>= 4:0.7.3-1) but<br> 4:0.8.3ubuntu0.12.04.1 is to be installed<br>
                      Depends: libavformat-extra-53 (>= 4:0.7.3-1) but 4:0.8.3ubuntu0.12.04.1 is to be installed
                      Depends: libavutil-extra-51 (>= 4:0.7.3-1) but 4:0.8.3ubuntu0.12.04.1 is to be installed
                      Depends: libc6 (>= 2.7) but 2.15-0ubuntu10 is to be installed
                      Depends: libglib2.0-0 (>= 2.31.2) but 2.32.3-0ubuntu1 is to be installed
                      Depends: libgstreamer-plugins-base0.10-0 (>= 0.10.31) but 0.10.36-1ubuntu0.1 is to be installed
                      Depends: libgstreamer0.10-0 (>= 0.10.31) but 0.10.36-1ubuntu1 is to be installed
                      Depends: liborc-0.4-0 (>= 1:0.4.16) but 1:0.4.16-1ubuntu2 is to be installed
                      Depends: libpostproc-extra-52 (>= 4:0.7.3-1) but 4:0.8.3ubuntu0.12.04.1 is to be installed
                      Depends: libswscale-extra-2 (>= 4:0.7.3-1) but 4:0.8.3ubuntu0.12.04.1 is to be installed gstreamer0.10-ffmpeg:i386: Depends: libavcodec-extra-53 (>= 4:0.7.3-1) but 4:0.8.3ubuntu0.12.04.1 is to be installed
                           Depends: libavformat-extra-53 (>= 4:0.7.3-1) but 4:0.8.3ubuntu0.12.04.1 is to be installed
                           Depends: libavutil-extra-51 (>= 4:0.7.3-1) but 4:0.8.3ubuntu0.12.04.1 is to be installed
                           Depends: libc6 (>= 2.7) but 2.15-0ubuntu10 is to be installed
                           Depends: libglib2.0-0 (>= 2.31.2) but 2.32.3-0ubuntu1 is to be installed
                           Depends: libgstreamer-plugins-base0.10-0 (>= 0.10.31) but 0.10.36-1ubuntu0.1 is to be installed
                           Depends: libgstreamer0.10-0 (>= 0.10.31) but 0.10.36-1ubuntu1 is to be installed
                           Depends: liborc-0.4-0 (>= 1:0.4.16) but 1:0.4.16-1ubuntu2 is to be installed
                           Depends: libpostproc-extra-52 (>= 4:0.7.3-1) but 4:0.8.3ubuntu0.12.04.1 is to be installed
                           Depends: libswscale-extra-2 (>= 4:0.7.3-1) but 4:0.8.3ubuntu0.12.04.1 is to be installed

Also, when trying to install system updates to packages it comes up with a error window from 'backhand_helper.py' says 'Packaging System is broken' and asks me to uninstall extra 3rd-party ppas. Clicking details says: `

The following packages have unmet dependencies:

libapt-pkg4.12: Depends: libc6 (>= 2.15) but 2.15-0ubuntu10 is installed
                Depends: libgcc1 (>= 1:4.1.1) but 1:4.6.3-1ubuntu5 is installed
                Depends: libstdc++6 (>= 4.6) but 4.6.3-1ubuntu5 is installed
                Depends: zlib1g (>= 1:1.2.2.3) but 1:1.2.3.4.dfsg-3ubuntu4 is installed
libapt-pkg4.12:i386: Depends: libc6 (>= 2.15) but 2.15-0ubuntu10 is installed
                     Depends: libgcc1 (>= 1:4.1.1) but 1:4.6.3-1ubuntu5 is installed
                     Depends: libstdc++6 (>= 4.6) but 4.6.3-1ubuntu5 is installed
                     Depends: zlib1g (>= 1:1.2.3.3.dfsg) but 1:1.2.3.4.dfsg-3ubuntu4 is installed

Thanks :))

share|improve this question

marked as duplicate by jokerdino, maythux, Eliah Kagan, devav2, Stephen Myall Oct 8 '12 at 10:06

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1  
I am voting to close this question as a duplicate since you have successfully solved your problem and the general instructions in the canonical question should be more than enough for the passers-by. –  jokerdino Oct 8 '12 at 9:14
    
sudo apt-get install ubuntu-restricted-extras worked for me. It installed a lot of other stuff, but it gets the job done. –  iamcreasy Mar 2 at 5:27

3 Answers 3

First Update the system By follwing command in terminal

sudo apt-get update

Fix dependencies using

sudo apt-get install -f

share|improve this answer
    
E: Internal Error, No file name for libapt-pkg4.12 –  Mochan Oct 3 '12 at 3:34

Run sudo apt-get update first.

Then you can successfully install gstreamer plugins.

As @ThiagoPonte said, install all gstreamer packages, so you wouldn't need to install extra codecs again.

Also check similar question: Unmet dependencies ubuntu 12.04?

share|improve this answer
    
I ran sudo apt-get install -f because sudo apt-get update didn't do anything. It came up with an error window suggesting me to use the first code and this came up: E: Internal Error, No file name for libapt-pkg4.12 –  Mochan Oct 1 '12 at 7:28
    
The window says 'The Package System is Broken' and wants me to uninstall 3rd-party ppas. Details show this: –  Mochan Oct 1 '12 at 7:56
    
It won't fit here so I'll include it above in the question description –  Mochan Oct 1 '12 at 7:57

If you are running Ubuntu 32-bit, run this on Terminal:

sudo apt-get -y install gstreamer0.10-pitfdll gstreamer0.10-ffmpeg gstreamer0.10-plugins-bad gstreamer0.10-plugins-bad-multiverse gstreamer0.10-plugins-ugly gstreamer0.10-plugins-ugly-multiverse

If you are running Ubuntu 64-bit, run this on Terminal:

sudo apt-get -y install gstreamer0.10-ffmpeg gstreamer0.10-plugins-bad gstreamer0.10-plugins-bad-multiverse gstreamer0.10-plugins-ugly gstreamer0.10-plugins-ugly-multiverse
share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.