Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using gnome-shell on Ubuntu 12.04. On the guest account, I have this handy option switch user, but when I am logged into my own account it is not there for some reason.

Why isn't it there anymore, and how can I get it back? At the moment I can use the workaround to lock screen and I get a switch user button from there, but it would be nicer to have the menu option as I was used to.

enter image description here

enter image description here

share|improve this question
    
did you install any extensions? – Anwar Shah Sep 25 '12 at 13:05
    
Creepy eye, dude. – JXPheonix Sep 25 '12 at 13:15
    
I think ubuntu doesn't show Switch user option when there are no any other User accounts other than guest .... – Prasad RD Sep 25 '12 at 14:38
    
@ Parasd --- You are wrong Switch user option is always shown – user61928 Sep 25 '12 at 14:59
up vote 0 down vote accepted

It's there for me in 12.04. I didn't have to do anything to get it other than have other userid's set up.

Here's a screenshot of it:

enter image description here

I think Anwar's question in his comment above is insightful. Have you installed any extensions? If so you may wish to remove them, reboot, and see if there is still a problem. If the problem goes away you can add them again one-by-one to see which one interferes.

After selecting Switch User I'm sent back to the Ubuntu login screen (lightdm) where I can choose another userid, enter a password, and select the kind of session I want to start. I was able to start another session that way (on virtual tty 9 in my case) and switch back forth with Alt-Ctrl-F7 and Alt-Ctrl-F9.

share|improve this answer
    
thanks, i don't have any extensions but it came back on its own! i have no idea why or how. i'm accepting your answer so that my question doesn't show up in unanswered searches. – wim Sep 27 '12 at 3:44

Gnome 3 displays the Switch User option only when you have multiple normal user accounts on your system with a user id between 1000 and 29999 (Debian, Ubuntu).

If you want to switch to a user account within the reserved id range of your distribution, you can lock the screen with Super+L or Ctrl+Alt+L and click on Log in as another user below the login form.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.