Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I would like to install the latest version of Bibletime (2.9.1) on my computer because the version in the official repositories (2.8.1) has a bug with the "Mag" feature. I had installed 2.9.1 on 12.04 32 bit through one of the following ppa's:

ppa:pkgcrosswire/ppa
ppa:pkgcrosswire/developer-testing

Now on an Ubuntu 12.04.1 64 bit, I'm getting a dependency issue. It seems that it depends on libsword8 but it should actually depend on libsword9 which is available in the repositories. See http://sword-dev.350566.n4.nabble.com/Ubuntu-12-04-td4577002.html

Can someone help me install this app please?

EDIT: apt-get install -f bibletime yields the following:

The following packages have unmet dependencies:
 bibletime : Depends: libsword8 (>= 1.6.2+dfsg) but it is not installable
             Depends: bibletime-data (= 2.9.1-0ubuntu0~r70~precise1) but 2.9.1-1~ppa2~precise is to be installed
E: Unable to correct problems, you have held broken packages.
share|improve this question
    
I requested backporting of Bibletime 2.9.1 to precise. See bugs.launchpad.net/precise-backports/+bug/1056320 –  To Do Sep 25 '12 at 16:58

4 Answers 4

Was able to find the library at:

https://launchpad.net/ubuntu/precise/i386/libsword8/1.6.2+dfsg-1

Donwload the .deb file, and install using:

sudo dpkg --install libsword8_1.6.2+dfsg-1_i386.deb

Then install BibleTime using:

 sudo apt-get install bibletime

I hope this helps

share|improve this answer

Actually that could be fixed with -f . open your terminal and type as

sudo apt-get install -f 
share|improve this answer
    
See my edit above –  To Do Sep 25 '12 at 13:35

I think the problem is that you don't need both ppas installed: you only want ppa:pkgcrosswire/ppa and not ppa:pkgcrosswire/developer-testing as well, as that is causing the problems you are experiencing. The latter ppa is trying to install 2.9.1-1~ppa2~precise and the former is trying to install 2.9.1-0ubuntu0~r70~precise1. The sword dependency issues are also related to the situation caused by the ppas.

So, please remove the ppas by following the instructions in this question, and then run the following to clean out the system:

sudo apt-get purge bibletime
sudo apt-get autoremove
sudo apt-get clean

Then add again just the ppa:pkgcrosswire/ppa with

sudo add-apt-repository ppa:pkgcrosswire/ppa

Then run sudo apt-get update and you should be able to install the latest version of bibletime.


If these instructions are unsuccessful, I can show you how to build it from source, as that is what I did. It is much better to compile rather than adding Debian repositories like the accepted answer recommends.

Firstly, follow just my instructions above for purging and removing bibletime, its files, and also its ppas (if any exist), so we can have a fresh start. To get the dependencies necessary for the program and its compilation, run:

sudo apt-get build-dep bibletime
sudo apt-get install build-essential checkinstall cmake

Download the source from sourceforge and check its md5 signature. Then unpack the source and cd to the downloaded folder and run

sudo ./build-release.sh

Note: The above command will build and install the program, but, alternatively, you could cd to the bibletime folder and run

./build-release.sh
cd build
sudo checkinstall --pkgname=bibletime --provides=bibletime

(Don't worry if you get errors after the build has finished, as changing directory to build and then running checkinstall does work.)

enter image description here

share|improve this answer
    
My first attempt was to add the first ppa but got a lot of dependecy issues. Then I removed it and added the second one and got the libsword8 issue. I'm hesitant to build from source because, from the little I know, this requires installing a lot of packages to compile, etc and that would "clutter" my system. –  To Do Sep 25 '12 at 16:50
up vote -1 down vote accepted

I managed to install Bibletime 2.9.1 on Ubuntu 12.04.1 64 bit. This is how:

  1. Added the following repository deb http://ftp.de.debian.org/debian sid main 2. In a terminal I typed sudo apt-get update
  2. Followed by sudo apt-get install bibletime ignoring the warning messages
  3. I removed the two software sources not to contaminate my system with other 'updates'
  4. sudo apt-get update for the second time to clean the package cache.
share|improve this answer
    
That repository is the entire Debian main repository! I wouldn't add it, it will all sorts of packages from Debian that will conflict with Ubuntu's packages. –  Flimm Jan 11 '13 at 14:01
    
I know. And that is why, in step 3 in my answer I removed the repo from the sources list. I ignored all the update notifications I got , installed the package I was interested in, then removed the repo and run the update again to remove the notifications. It worked. –  To Do Jan 11 '13 at 14:13
    
Wouldn't it be better to just download the package from packages.debian.org ? –  Flimm Jan 11 '13 at 14:14
    
Maybe, but .deb package management is 'trickier' for me. It is not so evident, for me, how to remove whatever a .deb file installs. With a ppa you can always ppa-purge in case of problems. Furthermore many .deb files give incompatibility errors. –  To Do Jan 11 '13 at 14:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.