Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an Ubuntu 12.04 64bit with QEMU/KVM & virt-manager 0.9.4 (latest compiled from source) installed

my problem is that all guest windows machines does not recognize usb2.0 ports:

  1. windows xp recognizes all usb devices as USB 1.0
  2. windows 7 recognizes usb controller as USB1.0 but does not recognize all usb devices (yellow mark)

my system is fully up-to-date and I have recently upgraded virt-manager from 0.9.1 to 0.9.4 and also upgraded to virtinst 0.600.3 and virt-viewer 0.5.4

The problem also existed in 0.9.1.

share|improve this question
1  
Is there a feature in 0.9.4 that you need which isn't in 0.9.1? Installing from source makes it impossible for someone to exactly replicate you setup to try and help. –  hbdgaf Sep 25 '12 at 12:06
1  
0.9.1 supported usb 2.0. have you followed this: linux-kvm.com/content/virt-manager-adds-support-usb2 ? you have to specify a usb 2.0 device –  hbdgaf Sep 25 '12 at 12:20
1  
i looked at the mailing list and it looks like there was more than one way to implement usb 2.0 support and there was some disagreement on how it should be implemented. have you tried adding the physical usb2.0 hub (echi) as the shared device instead of the virtual device? –  hbdgaf Sep 27 '12 at 11:54
1  
okay, last shot is it needs hardware virtualization or some manual xml editing about the vm in question. i saw some command-line examples on forcing the usb2.0 virtual device in, but i think it might require hardware virtualization to work. my laptop doesn't have that, so i can't take the testing any further –  hbdgaf Sep 27 '12 at 12:10

1 Answer 1

up vote 1 down vote accepted

The answer was Here

Issue the command virsh edit testmachine to open the XML, where testmachine is your machine name seen in virt-manager, and added the following lines to the <devices> section:

<controller type='usb' index='0' model='ich9-ehci1'>
  <address type='pci' domain='0x0000' bus='0x00' slot='0x07' function='0x7'/>
</controller>
<controller type='usb' index='0' model='ich9-uhci1'>
  <master startport='0'/>
  <address type='pci' domain='0x0000' bus='0x00' slot='0x07' function='0x0' multifunction='on'/>
</controller>
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.