Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've been trying to get sound working in Unreal Torunament for a couple of days now.

I'm using the native Unreal Tournament version, not wine or something like that. I have sound in all other games and media applications that I have tried.

In older ubuntu versions it worked fine. I'm now using kubuntu 12.04, I have all the alsa-oss and oss-compat packages installed.

I have followed most of the advice out there, and it all seems to fall on padsp and aoss.

My problem, however, is that even when trying to use padsp or aoss, I can't get any sound at all.

(Note UT has two output modes: ALAudio and Generic(OSS), I have tried both).

Is there some configuration required to use padsp or aoss correctly?

I have ran it like padsp ./ut and aoss ./ut

If using the AL backend in UT I get (both aoss and padsp give this):
Bound to
open /dev/dsp: Invalid argument
Audio initialization failed.

If using the OSS backend in UT I get (both aoss and padsp give this):
Bound to
Failed to open audio device.
Audio initialization failed.

Note that so far, I have gotten absolutely no sound.

Thanks for any help!

share|improve this question
up vote 1 down vote accepted

Ok, after trying and failing a lot I finally have sound in Unreal Tournament. It also runs at the right speed, so no more problems! Here are the important things I did:

In ~/.loki/ut/System/UnrealTournament.ini :


In UnrealTournament/bin/x86/ut (note this file should be where you installed UT), line 84 should read:

exec padsp "./ut-bin" -log $*

Thus running the executable with padsp, I have tried aoss here also, didn't work.

I think though, after several upgrades of my ubuntu install. That my sound setup have completely borked itself.

I followed this Ubuntu Forums post to delete all my pulseaduio configuration (or misconfiguration):

$ rm -r ~/.pulse ~/.asound* ~/.pulse-cookie
sudo rm /etc/asound.conf

You should probably make a backup of these files before attacking them. In addition, I reinstalled the pulseaudio packages and removed the alsa-oss package. Note however that this was probably not required.

Hope this can help someone else!

share|improve this answer

Try to install osspd:

sudo apt-get install osspd

or from here.

I had the same problem with Heroes 3 and Rune, and just find this package in synaptic. Now all sound related issues gone. You can run any older OSS app with it, and don't need to apply any file tweaks or command line option, just install it and run the application or game you want.

share|improve this answer

protected by Oli Jun 26 '13 at 8:37

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.