Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I type my modem configuration page IP in browser instead of showing configuration page it shows default web page for apache.What's wrong?Is there any IP conflict?

Thanks in advance

share|improve this question
    
What type of modem? –  karthick87 Dec 29 '10 at 17:18
    
@karthick87: ADSL modem (dlink) –  Nick.h Dec 29 '10 at 17:26
    
The default ip for ADSL model is 192.168.1.1..Enter that in your browser and see if it helps you.. –  karthick87 Dec 29 '10 at 17:30

3 Answers 3

The default apache page is only shown when you have apache installed on the target machine. It sounds like you're trying to access your own machine instead of the router.

Make sure you're accessing the default route ip address and not your own ip address. Example:

alt text

You can get to this by right clicking on the network icon and clicking "Connection Information"

share|improve this answer
    
IP is valid.checked it with both Connection Information and ifconfig. –  Nick.h Dec 29 '10 at 18:08
    
then your router is broken, please take it in for repair. –  Martin Owens -doctormo- Dec 29 '10 at 18:36

Is this a modem, or a router?

In most DSL setups, the modem and the router are NOT the same device. Typically, the modem is just the gateway to the internet and provides you with an IP address, however the modem needs some other device to GET the IP. Are you certain that your modem is also a router?

share|improve this answer

You don't say what is your IP and your modem's local IP, which will be useful to know as said by @Martin Owens -doctormo-

If your modem's IP were crashing against your computer's IP, you shouldn't have internet connection.

Now, what you are experiencing is a conflict with port 80 redirection. Which can be solved in an easy way but it requires you to know how to edit your redirections in order to make them call the appropiate port in your computer.

You can change what port is your computer's apache service listening to by dropping the next in a terminal:

sudo gedit /etc/apache2/ports.conf

This will open a file whose contents should look like this:

# If you just change the port or add more ports here, you will likely also
# have to change the VirtualHost statement in
# /etc/apache2/sites-enabled/000-default
# This is also true if you have upgraded from before 2.2.9-3 (i.e. from
# Debian etch). See /usr/share/doc/apache2.2-common/NEWS.Debian.gz and
# README.Debian.gz

NameVirtualHost *:80 
Listen 80

<IfModule mod_ssl.c>
    # If you add NameVirtualHost *:443 here, you will also have to change
    # the VirtualHost statement in /etc/apache2/sites-available/default-ssl
    # to <VirtualHost *:443>
    # Server Name Indication for SSL named virtual hosts is currently not
    # supported by MSIE on Windows XP.
    Listen 443 </IfModule>

<IfModule mod_gnutls.c>
    Listen 443 </IfModule>

Just change the line that reads:

Listen: 80

for the port number that you wish and let's see if this fixes the problem. If it does, you will have access again to your modem.

Nevertheless, changing the port from this file will make your http service unreachable in the net. Then, now, if you are having access to your modem, let's change the NAT table in order to make all the petitions made to port 8080, run into the port 80 of your computer.

When this rules are set, now you can return the Listen: 80 back in your ports.conf file.

I know this information may not be fully clear. But if you wish I can add further information. Just first perform this test and let's see what happens.

The results of this in your computer/modem may change my answer or delete it if this is not useful for you.

Good luck!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.